W3C home > Mailing lists > Public > www-style@w3.org > April 2013

Re: [css-variables][naming] Renaming 'var'

From: Brian Kardell <bkardell@gmail.com>
Date: Sat, 13 Apr 2013 19:04:05 -0400
Message-ID: <CADC=+jdsjr=PL7RF4zSKOzzZ=FwwuRRRgC=XfAtduAz3uetd3Q@mail.gmail.com>
To: fantasai <fantasai.lists@inkedblade.net>
Cc: www-style@w3.org
On Apr 13, 2013 6:41 PM, "fantasai" <fantasai.lists@inkedblade.net> wrote:
>
> So, at Rename the Web Forward [1], Sylvain and I concluded that it
> just might be better to use 'set-' as the prefix and 'get()' as the
> function name instead of 'var-' and 'var()'.
>
> p {
>   set-: green;
>   background: get();
> }
>
> This takes us closer to "custom properties" than "variables",
> (and has the added bonus of not being an abbreviation!)
>
> Thoughts?
>
> ~fantasai
>
> [1] https://twitter.com/sgalineau/status/322870478790344704
>
>

This has been proposed several times on the list and off: i fully support!!
Received on Saturday, 13 April 2013 23:04:33 UTC

This archive was generated by hypermail 2.3.1 : Monday, 2 May 2016 14:39:10 UTC