W3C home > Mailing lists > Public > www-style@w3.org > October 2012

Re: Replace document.elementFromPoint() and document.caretPositionFromPoint() by functions named like similar functions returning all elements under the given point

From: Sebastian Zartner <sebastianzartner@gmail.com>
Date: Mon, 29 Oct 2012 08:37:48 +0100
Message-ID: <CAERejNb+nPccrx_q-6+_nHq3XYNrp_Vwev7xWovNmY7qK=uZgQ@mail.gmail.com>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
Cc: www-style list <www-style@w3.org>
>
> Please file a bug with priority "enhancement"
>
Done:

https://www.w3.org/Bugs/Public/show_bug.cgi?id=19753

I don't think we should change the names.  You're right that they're
> not quite consistent with similar methods, but they're not bad enough
> to justify the cost of aliasing, I think.
>

I didn't talk of aliasing but replacing. Anyway, it seems all major
browsers already support them, so it's probably too late to do so.

Sebastian
Received on Monday, 29 October 2012 07:38:15 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:21:01 GMT