W3C home > Mailing lists > Public > www-style@w3.org > May 2012

Re: [css3-align] The Great Alignment Bikeshed

From: François REMY <fremycompany_pub@yahoo.fr>
Date: Tue, 15 May 2012 12:53:37 +0200
Message-ID: <2F7A001B3980464FB633ADF87E46809F@FREMYD2>
To: "CSS 3 W3C Group" <www-style@w3.org>
I like that proposal too, but I dislike the fact it hides that 
"justify-items" is an alias to "::layout-child { justify-outside }".

Wouldn't it be better if we had "item-justify-outside" or 
"child-justify-outside"?




-----Message d'origine----- 
From: Alan Stearns
Sent: Tuesday, May 15, 2012 12:31 PM
To: www-style@w3.org
Subject: Re: [css3-align] The Great Alignment Bikeshed

On 5/14/12 10:45 PM, "Tab Atkins Jr." <jackalmage@gmail.com> wrote:

>On Sun, May 13, 2012 at 4:21 PM, fantasai <fantasai.lists@inkedblade.net>
>wrote:
>> Set 3: Outside/Inside/Items
>>
>>   +--------X----------------Y------
>>  A | justify-outside  align-outside
>>  B | justify-inside   align-inside
>>  C | justify-items    align-items
>
>This is my favorite.

This is my choice as well. Grouping these related properties together with
justify and align coming first makes the most sense to me. I vastly prefer
items, as that conveys to me a group of discrete things to distribute. And
I have a slight preference for inside/outside over self/content. I do not
think 'box' should be used - it's too overloaded as a term. So I think
this should be the easiest set to explain to someone new to the concepts.

Thanks,

Alan
Received on Tuesday, 15 May 2012 10:54:08 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:54 GMT