W3C home > Mailing lists > Public > www-style@w3.org > April 2012

RE: [css3-flexbox] One final round of bikeshedding on property/value names?

From: Alex Mogilevsky <alexmog@microsoft.com>
Date: Wed, 25 Apr 2012 17:02:19 +0000
To: Tab Atkins Jr. <jackalmage@gmail.com>
CC: www-style list <www-style@w3.org>
Message-ID: <2C86A15F63CD734EB1D846A0BA4E0FC80E79A8F8@CH1PRD0310MB381.namprd03.prod.outlook.com>
± From: Tab Atkins Jr. [mailto:jackalmage@gmail.com] 
± Sent: Thursday, April 19, 2012 11:27 AM
± 
± On Tue, Apr 17, 2012 at 7:44 PM, Alex Mogilevsky <alexmog@microsoft.com> 
± wrote:
± > ± From: Tab Atkins Jr. [mailto:jackalmage@gmail.com] ± Sent: Monday, 
± > April 16, 2012 4:34 PM ± ± 'flex-align' becomes 'content-align'
± > ± 'flex-item-align' becomes 'box-align'
± > ± 'flex-line-pack' becomes 'content-pack'
± > ± 'flex-pack' becomes 'content-justify'
± >
± > I am not a fan of moving to generic properties, I can't say I am perfectly 
± happy with current naming. 'flex-item-align' and 'flex-line-pack' aren't the 
± best names I've seen.
± >
± > Do we have better ideas, or can we apply Fanatai's thinking within the 
± "flex-" set?
± 
± Let's see...
± 
± flex-align => flex-group-align
± flex-item-align => flex-align
± flex-pack => flex-group-justify
± flex-line-pack => flex-group-pack
± 
± Or, try it the other way around:
± 
± flex-align => flex-align
± flex-item-align => flex-box-align
± flex-pack => flex-justify
± flex-line-pack => flex-pack
± 
± I'm not sure if either of these are actually an improvement over what we 
± currently have.  :/  I'm inclined to just keep the current names until we get 
± the proper generic names.

I think I'll be with majority if I say I am not perfectly happy with the names but I would be just fine living with current set.

Just in case any tweaking happens to naming, my preferences are...

0) The most used properties should be shorter. If all four could be one word each (with "flex-" prefix of course) it would be kewl.

1) *flex-align* -- perfect as is.

It can be questioned which axis of flexbox "align" should describe. 
If there is any analogy with 'text-align' or HTML 'align', these are applied on axis that is orthogonal to block flow direction, exactly as it is used on flexbox.

2) *flex-item-align* -- it makes the most sense to be "flex-???-align" (as in most proposed options). "item" looks unusual, but there is 'list-item' for a precedent. "child" would be confusing (who's child?). "box" doesn't say what it applies to either.

Making 'flex-align' apply to flex item and having a longer name for flexbox-level align goes against my preference (0)

3) *flex-pack* -- can have a number of alternatives, about equally attractive:

	-compact
	-fill
	-justify
	-arrange
	-adjust
	-shift
	-cluster

None sound much better to me, but I am already used to "-pack"...

4) *flex-line-pack* could actually become one word (maybe one of the above synonyms). I don't mind it being long though (it should be rare), and I think it would sound better if it was 'flex-wrap-???", showing clearly that it only affects content that wraps.

'flex-wrap-pack' would sound reasonable and intuitive.
'flex-wrap-align' would actually sound reasonable too. 

"-pack" works because same values apply, with the same effect. 
"-align" could work because it is in the same direction as 'flex-align'.

I could live with either.

That's about as much as I would be interested in changing. Not much, but if an awesome name comes up, I want to hear))

Alex

 
Received on Wednesday, 25 April 2012 17:03:22 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:52 GMT