W3C home > Mailing lists > Public > www-style@w3.org > May 2010

RE: [flex-units] unit abbreviations and the flex()

From: Sylvain Galineau <sylvaing@microsoft.com>
Date: Fri, 28 May 2010 20:21:55 +0000
To: Zack Weinberg <zweinberg@mozilla.com>, Andrew Fedoniouk <news@terrainformatica.com>, W3C Emailing list for WWW Style <www-style@w3.org>
Message-ID: <045A765940533D4CA4933A4A7E32597E21495AFF@TK5EX14MBXC120.redmond.corp.microsoft.com>
> From: www-style-request@w3.org [mailto:www-style-request@w3.org] On
> Behalf Of Zack Weinberg

> [re '1*' not being a DIMENSION]
> > Existing syntax just needs these two updates:
> >
> > PERCENTAGE	::=	num '%'
> > FLEX	                ::=	num '*'
> >
> > any        : [ IDENT | NUMBER | PERCENTAGE | DIMENSION | STRING |
> FLEX
> >               | DELIM | URI | HASH | UNICODE-RANGE | INCLUDES
> >               | FUNCTION S* any* ')' | DASHMATCH | '(' S* any* ')'
> >               | '[' S* any* ']' ] S*;
> >
> > I do not see any problems with this, do you?
> 
> You're proposing a change in the CSS2.1 generic syntax.  I don't
> think that's worth doing just for the (arguable) additional
> readability of '1*' over '1fl'.

I agree. And if flex can be used in calc(), I don't find * adds any
readability as length unit since it's also an operator in this context.
Received on Friday, 28 May 2010 20:22:29 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:27 GMT