W3C home > Mailing lists > Public > www-style@w3.org > April 2010

Re: [css3-animations] Property Naming Proposals

From: Brad Kemper <brad.kemper@gmail.com>
Date: Mon, 5 Apr 2010 23:56:16 -0700
Cc: "www-style@w3.org" <www-style@w3.org>
Message-Id: <13A70F99-9FB8-4CC6-B9A2-87F28E2E3752@gmail.com>
To: fantasai <fantasai.lists@inkedblade.net>

On Apr 5, 2010, at 3:30 PM, fantasai wrote:

> There were a a couple proposals at the F2F that I wanted to make
> sure didn't get lost.
> 
> From Bert:
>  Rename animation-iteration-count to animation-play-count
>    * easier to spell
>    * consistent with marquee-play-count
> 
> From Tantek:
>  Rename animation-duration to animation-period
>    * Avoids confusion about whether it refers to the duration
>      of a cycle, or the total length of the animation. (This
>      kind of mix-up came up several times during the discussion.)

I agree that both those changes would be improvements.

> Bert also mentioned thinking about the difference between
> animation-direction and marquee-direction.

Yeah, 'direction' seems to make more sense for the forward/reverse values of marquee, than for alternate or not. 'Alternate' is not really a direction (it also has two different pronunciations based on if it is a verb or an adjective). Maybe it should be something like 'animation-loop: restart | reverse'

> I'll tack on a fly-by suggestion from me (could be totally off):
>  Rename animation-fill-mode to animation-extend: start | end | both
>    * We have enough "fill" concepts already
>    * Avoids semantically-empty "mode" component

True. I like 'extend'. But we also have 'start | end' concepts. How about 'animation-extend: begin | finish | both'?



Received on Tuesday, 6 April 2010 06:56:50 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 17:20:26 GMT