W3C home > Mailing lists > Public > www-style@w3.org > March 2001

Re: css3 :nth-child() WD

From: Jonas Sicking <sicking@bigfoot.com>
Date: Fri, 2 Mar 2001 19:02:37 +0100
Message-ID: <02cc01c0a342$f7309860$5412a8c0@Milwork08>
To: <www-style@w3.org>
I agree my proposal is a bit more complicated but it also adds much extra
functionallity, such as rules for "three lines white, three lines gray..."
(see previous post). Also the whitespace could be removed using fantasis
suggestion to use '..' instead of 'to', ie
:nth-child(6n+1..3)

Actually one of my original reasons to remove negativ a and b was to
simplify implementation...

Of course one way to go would be to combine the to syntaxes. Have the
currently drafted syntax and add the 'to'/'..' syntax for ranges

/ Jonas Sicking

----- Original Message -----
From: "Daniel Glazman" <glazman@netscape.com>
To: "Robin Berjon" <robin@knowscape.com>
Cc: <www-style@w3.org>
Sent: Friday, March 02, 2001 9:25
Subject: Re: css3 :nth-child() WD


> Robin Berjon wrote:
>
> >> I think this may be a bit clearer to use than the 6n+1 to 10 notation
> >> proposed earlier.
> >
> >
> > I totally agree ! cron-style notation is by far easier to read. I also
> > think it's generally far more intuitive than the an+b notation.
>
> More people in the unix community, probably. Seriously, try to put a
> web author in front of a crontab entry and take a look at his face...
> This is CSS, not a subdirectory of /var/spool
>
> I don't like Sicking's proposal for the following reasons :
>
> 1. I think that Tantek's father's suggestion which is in the current
>    Last Call WD is elegant and simple, for both implementors and users,
> 2. I don't want to see a coding whitespace in the argument of a pseudo
>    unless this whitespace is a descendant combinator,
> 3. we have a general agreement from all implementors on the current syntax
> 4. it took me, editor of the WD, fifteen seconds to understand your
syntax.
>
> The an+b notation is in between cron's notation and Sicking's proposal. I
> am not at all in favor of a change.
>
> </Daniel>
Received on Friday, 2 March 2001 13:01:48 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 27 April 2009 13:54:08 GMT