W3C home > Mailing lists > Public > www-rdf-interest@w3.org > July 2003

RE: rdfs:resource

From: Jon Hanna <jon@spin.ie>
Date: Fri, 25 Jul 2003 16:18:16 +0100
To: <www-rdf-interest@w3.org>
Message-ID: <NDBBLCBLIMDOPKMOPHLHAEECFGAA.jon@spin.ie>

> > <cims:qualifierFlavor> <rdfs:subProperty> <cims:NamedElement> .
> > Entails that both <cims:qualifierFlavor> and <cims:NamedElement> are
> > properties, and as such it is possible to say <A>
> <cims:NamedElement> <B>.
>
> Yes, and that is a problem. In my view this is wrong as the NamedElement
> is "conceptual" or restriction (if you prefer), i.e. it states that all
> CIM elements must be named.

I don't think it's a problem. It's still possible to say that
<cims:qualifierFlavor> <rdf:type> <cims:NamedElement>.
And similarly for its range and domain. Further subPropertys of
qualifierFlavor will have ranges and domains that are the same or compatible
with qualifierFlavor, so they would inherit the restriction that those must
be NamedElements.

So it can still be entirely rooted in NamedElement if that's what you
desire.
Received on Friday, 25 July 2003 11:15:25 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:52:00 GMT