W3C home > Mailing lists > Public > www-lib@w3.org > October to December 2002

Re: a sad tale of libwww installation

From: Richard Atterer <libwww@list02.atterer.net>
Date: Tue, 15 Oct 2002 00:40:34 +0200
To: Ritz Coder <ritzcoder@yahoo.com>
Cc: www-lib@w3.org
Message-ID: <20021014224034.GB8352@nenya.lan>

Hi,

if anybody is interested in a libwww for Winodws built with gcc, you
might want to have a look at my libwww 5.4.0 binary libs at

  http://atterer.net/jigdo/#source

They were built with mingw GCC, but should also work with Cygwin's
GCC. I used --without-expat to build them.

On Mon, Oct 14, 2002 at 11:43:29AM -0700, Ritz Coder wrote:
> $ gcc -o test `libwww-config --cflags`
> Library/Examples/showlinks.c `libwww-config --libs`
> /usr/local/lib/libwwwapp.a(HTInit.o): In function
> `HTConverterInit':
> /home/admin1/libwww/Library/src/HTInit.c:87: undefined
> reference to `HTXML_new'
> /home/admin1/libwww/Library/src/HTInit.c:88: undefined
> reference to `HTXML_new'
> 
> I believe that this has something to do with expat
> missing (although according to the docs expat is
> compiled in by default) To be safe, I did make
> distclean, deleted everything (including the libs),
> brought down the source again form cvs, and ran
> configure with all kinds of options including
> --with-expat --enable-expat, etc.  Nothing works!!

Did you also delete your application's object files? I know for
certain that exactly the above error occurs in the following case:

 - Compile and install libwww --without-expat
 - Compile user code against that version of libwww
 - Recompile and install libwww --with-expat
 - Try to link the user code against the new libwww
   ("Link" can also mean runtime linking.)

> Of course this is just my development machine, If I ever get this to
> work, I wanted to incorporate it into a program I am building that
> will live on a RedHat 8 linux machine.

Of course I could now point out that I'm the maintainer of the Debian
Linux libwww packages and that my packages are well-tested and work
just fine...

...but no, I won't point that out. :-)

> Great - I'll just find the libraries and compile a sample program. 
> Except doing a locate I cannot find the libraries anywhere on the
> system.

Are you aware that the "locate" database is only rebuilt every 24
hours? If you use that command immediately after installing new
software, none of the files of that software will be found.

> After this, I run the bootstrap perl config/winConfigure.pl
>  line and and get these messages:
> 
> assuming global: PUBLIC FILE *WWWTrace = NULL;
> assuming global: PUBLIC unsigned int WWW_TraceFlag =
> 0;         /* Global trace
> flag for ALL W3 code */
> assuming global: PUBLIC int ParseDebug = 0;     /* For
> use with LablPars and RatPars */
> 
> Ok. Not sure if there was a problem or not yet.  

No, it's not a problem.

> Now I run the following:
> [root@localhost libwww]# aclocal; autoheader;
> automake; autoconf
> 
> and I get these messages:
> 
> aclocal: macro `fp_PROG_INSTALL' defined in
> acinclude.m4 but never used
> WARNING: Using auxiliary files such as `acconfig.h',
> `config.h.bot'
[...]

You're bootstrapping with autoconf 2.5x, but libwww needs autoconf
2.13.

> Not one to give up, I download the tar file (instead of using cvs)
> and try this next. As I do configure for this I get messages such as
> unary operator expected and others that tell me that this is not
> working at all.

That's weird, "unary operator expected" and similar is usually a sign
that your shell is non-standard. No idea what might be causing this.

Cheers,

  Richard

-- 
  __   _
  |_) /|  Richard Atterer     |  CS student at the Technische  |  GnuPG key:
  | \/¯|  http://atterer.net  |  Universität München, Germany  |  0x888354F7
  ¯ '` ¯
Received on Monday, 14 October 2002 18:40:20 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:42 GMT