W3C home > Mailing lists > Public > www-lib@w3.org > October to December 2002

a sad tale of libwww installation

From: Ritz Coder <ritzcoder@yahoo.com>
Date: Mon, 14 Oct 2002 11:43:29 -0700 (PDT)
Message-ID: <20021014184329.16048.qmail@web20105.mail.yahoo.com>
To: www-lib@w3.org

Hi.  I am trying to get libwww to work and I am having
all kinds of problems.  I would very much appreciate
help from anyone out there who can get this to work. 
Here is my tale of woe so far:

On a Windows XP machine with the full installation of
cygwin:
I downloaded the cvs and followed the instructions for
bootstrapping, configuring and compiling and
installing.  Everything seemed to install fine and I
have a new directory /usr/local/lib/ where the .a
files live.  I try to run a very basic example (the
Library/Examples/libapp_1.c) file using the same line
given in the instructions (shown below):
gcc -o test `libwww-config --cflags`
Library/Examples/libapp_1.c `libwww-config --libs`
The program builds fine and seems to run
The sample file is:
#include "WWWLib.h"

int main()
{
    HTLibInit("TestApp", "1.0");
    HTLibTerminate();
    return 0;
}

This works fine. Now when I want to build something
that will acutally be useful (like the showlinks.c
sample), I get the following error:
$ gcc -o test `libwww-config --cflags`
Library/Examples/showlinks.c `libwww-config --libs`
/usr/local/lib/libwwwapp.a(HTInit.o): In function
`HTConverterInit':
/home/admin1/libwww/Library/src/HTInit.c:87: undefined
reference to `HTXML_new'
/home/admin1/libwww/Library/src/HTInit.c:88: undefined
reference to `HTXML_new'

I believe that this has something to do with expat
missing (although according to the docs expat is
compiled in by default) To be safe, I did make
distclean, deleted everything (including the libs),
brought down the source again form cvs, and ran
configure with all kinds of options including
--with-expat --enable-expat, etc.  Nothing works!!

Of course this is just my development machine, If I
ever get this to work, I wanted to incorporate it into
a program I am building that will live on a RedHat 8
linux machine. At this point I decide that I better
see if I can get this thing to compile on the
production machine before I do any more work.  Haha -
this turns out to be even more difficult than cygwin. 
Here is what I tried:

First, I do an rpm -qa on the Linux box and there are
already these two packages:
w3c-libwww-5.4.0-1
perl-libwww-perl-5.65-2

Great - I'll just find the libraries and compile a
sample program. Except doing a locate I cannot find
the libraries anywhere on the system.  So I go through
the routine of downloading from cvs again on this
machine.  After this, I run the bootstrap perl
config/winConfigure.pl
 line and and get these messages:

assuming global: PUBLIC FILE *WWWTrace = NULL;
assuming global: PUBLIC unsigned int WWW_TraceFlag =
0;         /* Global trace
flag for ALL W3 code */
assuming global: PUBLIC int ParseDebug = 0;     /* For
use with LablPars and RatPars */

Ok. Not sure if there was a problem or not yet.  
Now I run the following:
[root@localhost libwww]# aclocal; autoheader;
automake; autoconf

and I get these messages:

aclocal: macro `fp_PROG_INSTALL' defined in
acinclude.m4 but never used
WARNING: Using auxiliary files such as `acconfig.h',
`config.h.bot'
WARNING: and `config.h.top', to define templates for
`config.h.in'
WARNING: is deprecated and discouraged.

WARNING: Using the third argument of `AC_DEFINE' and
WARNING: `AC_DEFINE_UNQUOTED' allows to define a
template without
WARNING: `acconfig.h':

WARNING:   AC_DEFINE([NEED_MAIN], 1,
WARNING:             [Define if a function `main' is
needed.])

WARNING: More sophisticated templates can also be
produced, see the
WARNING: documentation.
aclocal.m4:268: error: m4_defn: undefined macro:
_m4_divert_diversion
autoconf/c.m4:1033: AC_C_VOLATILE is expanded from...
aclocal.m4:268: the top level
autoheader: autom4te-2.53 failed with exit status: 1
 at /usr/bin/autoheader line 163
ComLine/src/Makefile.am: required file
`config/depcomp' not found
/usr/share/automake-1.6/am/compile.am: CPPFLAGS was
set with `:=' and is now set with `='
Makefile.am:45: `#' comment at start of rule is
unportable
configure.in:30: required file `./wwwconf.h.in' not
found
aclocal.m4:268: error: m4_defn: undefined macro:
_m4_divert_diversion
autoconf/c.m4:1033: AC_C_VOLATILE is expanded from...
aclocal.m4:268: the top level


I tried all the suggestions in the help (make
distclean, give aclocal the -I path of libtool, etc
but nothing works.  So just for for I try to
./configure

Of course this does not work because there is no
configure file and I am stuck. 

Not one to give up, I download the tar file (instead
of using cvs) and try this next.  As I do configure
for this I get messages such as unary operator
expected and others that tell me that this is not
working at all.

Now I am really stuck and my only recourse is to ask
for help. Any help would be appreciated. I would
really like to use this library (as you can probably
tell ) because it promises a cross platform solution.
Of course, as it stands, I have it working on no
platforms at all!  Thanks very much.


__________________________________________________
Do you Yahoo!?
Faith Hill - Exclusive Performances, Videos & More
http://faith.yahoo.com
Received on Monday, 14 October 2002 14:43:30 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:42 GMT