W3C home > Mailing lists > Public > www-lib@w3.org > January to March 1999

NETREAD hangs when loading URL that sets cookie.

From: Abe Lederman <lederman@iwapps.com>
Date: Sun, 21 Feb 1999 14:41:06 -0700
Message-ID: <36D07D72.6077A3A8@iwapps.com>
To: www-lib@w3.org
I have a problem that is driving me nuts.

I'm running version 5.2.1 of libwww (I have also tried this on a
snapshot of CVS that I downloaded
yesterday) on a Solaris 2.5.1 machine.

When I do a POST (problem also occurs when doing a GET) against a HTTP
1.0 server, and a Set-Cookie header is returned, libwww hangs in the
NETREAD call in HTReader.c

The problem doesn't occur if the Set-Cookie header isn't returned, and
the problem doesn't occur
when talking to a newer 1.1 server.

When running non-preemptively, then libwww hangs in a select and it
looks like the server is returning the URL correctly.

I have tried setting connection mode to HTTP_FORCE_10 and it hasn't made
a difference.

Any help would be greatly appreciated.
Received on Sunday, 21 February 1999 16:33:45 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:28 GMT