W3C home > Mailing lists > Public > www-lib@w3.org > April to June 1998

Re: Building libwww & ComLine on Windows NT.

From: Bob Racko <bobr@dprc.net>
Date: Sat, 6 Jun 1998 16:33:13 -0400 (EDT)
Message-Id: <3.0.3.32.19980606161546.009fa780@shell14.ba.best.com>
To: Jeff Cochand <cochand@pobox.com>, www-lib@w3.org
Cc: Henrik Frystyk Nielsen <frystyk@w3.org>
>    I've tried to compile the Library and ComLine on my up to date NT 4.0 &
>VC++ machine.  I'm a very experienced Unix & NT developer, but have had all
>kinds of problems totalling 3 hours of thus far non-productive effort.
>Maybe you can help? 
>    First I tried to compile ComLine using nmake at the dos prompt.  I went
>thru a series of gyrations - setting up paths, commenting out seemingly
>unnecessary includes (sysdep.h I think), etc.  I then realized I needed to
>compile the Library first. 
yes. make the library first.
though commenting out sysdep.h everywhere
is modifying too many files.
it is easier to go back to the 5.1L release and get that one.
if you cannot get a sysdep.h
commenting it out is the same effect as having an empty one.

>    I started with nmake on that & had a similar experience.  I think I got
>pretty close - a Bin directory was created with www core, dll, stream, and
>utils dll & ilk files in it.  Then it started complaining about not finding
>include files (STAT.H).  Eventually I got into VC++, let it create a
>project based on your makefile and got to the point of: 
>    ..\..\External\zlib.lib : fatal error LNK1106: invalid file or disk
>full: cannot seek to 0xb5a

I found that zlib.lib was corrupted in 5.1m
the one from 5.1L is ok.

><<<<
>
>I think zlib may have been corrupted by my CVS 
my copy was corrupted in the .zip file.
I do not use CVs.


>I have an External\zlib.lib.  The disk isn't full, I guess the file is
>invalid.  I bagged out thinking maybe my hacking of the makefile screwed
>something up. 

>    I started over, clean unzip (which doesn't smoothly unzip BTW),
it smoothly unzips if you use winZip.
I had problems with zip204g

> right
>into VC++ with Library\src\windows.  For some reason I get the error: 
> LINK : fatal error LNK1104: cannot open file
".\../../../Bin/Debug\wwwdll.dll
aah yes, another problem is that
nmake requires some of the directories to already exist
but an entirely empty directory doesnt always get created
by the zipup utils. mkdir Bin\Debug fixed that for me. (note caps)

 
>Obviously I got past this the first time, as a bin\debug dir exists as
>described above, however I've lost confidence in the entire build process
>you guys have set up.  

>I'm going thru a lot of hassle & am skeptical of
>w3c/ComLine ever doing the job for me.  Any advice?
have patience. there are others in your boat
(me for one)

you will find that even once you build it
there will be immedaite problems
when you specify a rule file
and exceptions galore while it is running
(including a few during shutdown).

I will be posting some bug fixes shortly.
I myself am working with the robot
but the problems are in HTfile and HTchunk 
so the would affect comline too.

- Bob Racko

Site Manager, Mozilla Contributor Development
http://mozilla.devel.org/noreg/moz/news.cgi/start
Received on Saturday, 6 June 1998 19:46:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:27 GMT