W3C home > Mailing lists > Public > www-jigsaw@w3.org > November to December 1999

Strange behaviour with NegotiatedFrame...

From: Roland Mainz <Roland.Mainz@informatik.med.uni-giessen.de>
Date: Thu, 25 Nov 1999 03:41:04 +0100
Message-Id: <383CA1C0.3B16EB58@informatik.med.uni-giessen.de>
To: W3 Jigsaw Mailinglist <www-jigsaw@w3.org>

Hi !

----

Sometimes at our homepage a image got lost (e.g. the resourcees were
still there, and the file itself was accessible. But the NegotiatedFrame
returned "document contains no data"). No problem, normally the next
server reboot wiped-out the problem. But not this Monday.
After some playing around I found some interesting details:

The image has the URI "/icons/imi-logo" and is a NegotiatedFrame which
links to "imi-logo.gif". Deleting both resources nor the complete
"/icons" directory resource fixed the problem (BTW: The "default"
directory's DirectoryResource for the "icon" indexer hasn't it's indexer
attribute set to "icon". Is this correct/a wanted behaviour ??).
After all, the solution was to _rename_ the _file_ on _disk_ to
"imilogo.gif", and all problems went away.
Any hint what's going  on here ??

We're using the 19990809 jigsaw developer version...

----

Bye,
Roland

--
  __ .  . __
 (o.\ \/ /.o) Roland.Mainz@informatik.med.uni-giessen.de
  \__\/\/__/  gisburn@informatik.med.uni-giessen.de
  /O /==\ O\  MPEG specialist, C&&JAVA&&Sun&&Unix programmer
 (;O/ \/ \O;) TEL +49 (0) 641/99-13193 FAX +49 (0) 641/99-41359
Received on Wednesday, 24 November 1999 21:41:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:34 GMT