W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 1998

Re: Servlets problem in IE4 only

From: Roman Dusek <dusek@kolej.mff.cuni.cz>
Date: Thu, 04 Jun 1998 15:32:59 +0200
Message-Id: <Version.32.19980604131946.00d83b00@mail.kolej.mff.cuni.cz>
To: Jigsaw conference <www-jigsaw@w3.org>
Cc: jigsaw@w3.org
Hi,
I would like to provide some more detailed informations about my problem
with servlets in IE4, that I posted to the conference some time ago (copy
included). I feel there is some bug in here.

I grabbed the packets of the Jigsaw response to IE. The first contains all
the HTTP headers of the response, and the first part of the data. It's OK.
But, and that is IMO the problem, the second packet, that should contain
only the data part of the rest of the response, are in my packet-grabber
(NetXRay v2.0) viewed also like a headers part (this part includes the
output from the servlet) and data part. I think IE interprets it the same
way as NetXRay does, and that is the problem.

Well, I'm not too skilled in TCP/IP packet structure and rules, but I hope
this info could be helpful to find the bug.

To complete the informations, I have Jigsaw 2.0b1 running by JDK 1.1.6 on
WinNT 4.0

Sincerely,
Roman Dusek

At 00:22 2.6.1998 +0200, I wrote:
>Hi,
>I've got a strange problem with servlet invoking by SSI. I've written a
>very simple servlet:
>
>---------------------------------
>import java.io.*;
>import javax.servlet.*;
>
>public class TestServlet extends GenericServlet  {
>
>public void service(ServletRequest req, ServletResponse res) 
>     throws ServletException, IOException {
>
>	System.out.println("TestServlet started.");
>	PrintStream out = new PrintStream(res.getOutputStream());
>	out.println("Hello World!");
>	System.out.println("TestServlet finished.");
> }
>
> public String getServletInfo() {
>   return "Hello World Servlet";
> }
>}
>-----------------------------------
>
>and successfully installed it in /servlets/TestServlet. I have no problem
>to access it directly (http://localhost/servlets/TestServlet). I've also
>written a html file that tries to invoke it by SSI call:
>
>-----------------------------------
><body>
><hr>
><!--#servlet name="TestServlet" code="/servlets/TestServlet" -->
><hr>
></body>
>----------------------------------
>
>- the strange thing is, that this resource (of course I've got an SSIFrame
>attached to it) works with no problem in Netscape v. 3 and 4, but it
>doesn't work in Internet Explorer 4 - I am getting one of the following
>message boxes:
>
>"Internet Explorer cannot open the Internet site http://localhost/test.shtml.
>The downloaded file is not available. This could be due to your Security or
>Language settings or because the server was unable to receive the requested
>file"
>
>OR
>
>"Internet Explorer cannot open the Internet site http://localhost/test.shtml.
>An internal error occured in the Windows Internet extensions."
>
>I tried to change the extension of "test.shtml" to "test.html", but the
>result was still the same. Maybe another important thing is that Jigsaw
>doesn't show any error (even in its trace mode).
>
>Does anybody know what could be the problem?
>
>Thanks, 
>R. Dusek
> 	
> 
Received on Thursday, 4 June 1998 09:34:27 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:27 GMT