W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1997

Re: Strange things with VirtualHost

From: Martin Wille <m@ifib.uni-karlsruhe.de>
Date: Wed, 02 Jul 1997 13:30:01 +0200
Message-Id: <199707021130.NAA13908@ifib7.ifib.uni-karlsruhe.de>
To: "'Jigsaw Mailing List'" <www-jigsaw@w3.org>

RaphaŽl MARTIN <rmartin@iri.upc.es> wrote:
> Hi
> 
> I observe very strange things with Virtual Hosting :
> 
> I have defined a Virtual Host within two PassDirectory (HOST1,HOST2)
> 
> To consult documents and browse HTML files resources, I have no
> problem... http://HOST1/SubDir1/SubDir1_1/File.html works perfectly.
> 
> But, when I intent to get an URL such as
> http://HOST1/SubDir1/SubDir1_1/ to have the directory index I could
> have two special results :
> If I forget the last '/', I have the HTTP Error :
> Resource unavaible :  
> http://HOST1/HOST1/SubDir1/SubDir1_1 
> And if I put the final '/' for the request , I have the Index, but all the
> references are :
> http://HOST1/HOST1/SubDir1/SubDir1_1/File1.html
> http://HOST1/HOST1/SubDir1/SubDir1_1/File2.html
> http://HOST1/HOST1/SubDir1/SubDir1_1/File3.html
> 
> So why does the server duplicate the HostName (PassDirectory name),
> using a Virtual Host ?
> 
> A few hints to help :
> I use a Jigsaw Alpha1.05 
> I use a Netscape Gold 3.10
> 
> 						RAF
Hi

I ran into the same problem and things turned out to be even worse: when I ran 
the salvager parts of my configuration were lost, since many of the resource 
storages were deleted although they had not been obsolete.

My (not very proper) workaround:
	1. I never use the salvager
	2. I installed a cgi which relocates requests of the form
	   http://HOST1/HOST1/... to the proper location adding the trailing 
slash if needed.

Martin Wille.
Received on Wednesday, 2 July 1997 07:30:16 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:26 GMT