W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 1997

Error Indexing

From: Anselm Baird_Smith <abaird@www43.inria.fr>
Date: Tue, 14 Jan 1997 08:30:08 +0100 (MET)
Message-Id: <199701140730.IAA14101@www43.inria.fr>
To: Weiyeh Lee <weiyeh@pencom.com>
Cc: www-jigsaw@www10.w3.org
Weiyeh Lee writes:
 > Hi everyone,
 > 
 > I'm having a problem indexing cgi files on the jigsaw server.
 > I did not find anything that was related in the archives.
 > 
 > This is what we did:
 > 
 > 	We have excite in a Excite directory under ~Jigsaw/WWW/Excite
 > 	But none of the cgi scripts showed up in that directory
 > 	when we tried to look at http://localhost/Excite/
 > 	
 > 	We saw the html files, but no cgi's, so we 
 > 
 > 	1. Added a new extension
 > 	
 > 		Name: cgi
 > 		Class: w3c.jigsaw.forms.CgiResource
 > 
 > 	2. Went to the editor and reindexed Excite

I guess the scripts you want to index all have the ".cgi" extension ?
If this is the case, then you might be hitting a bug :-(

 > Now when we click on Excite under the Editor page, we get an error
 > saying the document contains no data.
 > 
 > Also in the errlog file we see:
 > 
 > <c1;client1>: caught exception [java.lang.NullPointerException] null

If you turn Jigsaw in trace mode (add -trace to the command line), you
should be able to get more infos (ie where the exception is thrown).

 > Before we did this, we could at least see the html files, but now we
 > can't see anything under Excite with the Editor.

That's strange, have you tried querying one the html files, by
pointing a browser to /Excite/xxx.html ?

Anselm
Received on Tuesday, 14 January 1997 02:30:11 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:25 GMT