W3C home > Mailing lists > Public > www-isaviz@w3.org > October 2004

ARP exception when import model

From: Andrea Furregoni <furre80@aliceposta.it>
Date: Wed, 6 Oct 2004 10:58:50 +0200
To: <www-isaviz@w3.org>
Message-ID: <000f01c4ab82$b635e4e0$4f213452@notebook>
I install Isaviz 2.0 and dot on winxp with java 1.4. when i try to
import a rdf model (for example the default files in export dir) it take
an exception, when the loader try to initialize the ARP(jena). 
 
 
C:\Java\IsaViz>java.exe -classpath
lib\isaviz.jar;lib\zvtm.jar;lib\jena.jar;lib\
xercesImpl.jar;lib\xmlParserAPIs.jar;lib\icu4j.jar;lib\antlr.debug.jar;l
ib\junit
.jar;lib\log4j-1.2.7.jar;lib\jakarta-oro-2.0.5.jar org.w3c.IsaViz.Editor
java.lang.NoSuchMethodError:
org.apache.xerces.parsers.SAXParser.<init>(Lorg/apa
che/xerces/xni/parser/XMLParserConfiguration;)V
        at
com.hp.hpl.jena.rdf.arp.ARPFilter$MySAXParser.<init>(ARPFilter.java:1
37)
        at com.hp.hpl.jena.rdf.arp.ARPFilter.create(ARPFilter.java:161)
        at com.hp.hpl.jena.rdf.arp.JenaReader.<init>(JenaReader.java:82)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
 
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
orAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
onstructorAccessorImpl.java:27)
        at
java.lang.reflect.Constructor.newInstance(Constructor.java:274)
        at java.lang.Class.newInstance0(Class.java:306)
        at java.lang.Class.newInstance(Class.java:259)
        at
com.hp.hpl.jena.rdf.model.impl.RDFReaderFImpl.getReader(RDFReaderFImp
l.java:95)
        at
com.hp.hpl.jena.rdf.model.impl.ModelCom.getReader(ModelCom.java:174)
        at org.w3c.IsaViz.RDFLoader.initParser(RDFLoader.java:171)
        at org.w3c.IsaViz.RDFLoader.load(RDFLoader.java:207)
        at org.w3c.IsaViz.Editor$4.construct(Editor.java:531)
        at com.xerox.VTM.engine.SwingWorker$2.run(SwingWorker.java:123)
        at java.lang.Thread.run(Thread.java:536) 
 
 
 
How can i resolve this problem? Someone has the same problem?
 
 
Andrea
Received on Wednesday, 6 October 2004 08:59:47 GMT

This archive was generated by hypermail 2.2.0 + w3c-0.30 : Friday, 25 March 2005 11:19:58 GMT