W3C home > Mailing lists > Public > www-isaviz@w3.org > May 2004

AW: Problem with the import local RDF-File

From: Kianoush Eshaghi <kianoush.eshaghi@metadat.at>
Date: Fri, 7 May 2004 15:53:17 +0200
To: "'Emmanuel Pietriga'" <epietriga@nuxeo.com>
Cc: <www-isaviz@w3.org>
Message-ID: <000f01c4343a$a75157d0$040a0a0a@metadat.metadat.at>
Hi,

I would say, that the version 1.8.2 of GraphViz would run by my machine. I
have tried often to import several local well-parsed RDF-files in IsaViz,
always unsuccessfully, but I have not had any problems with the export.

You get a RDF-file as attachment.

Thanks for your supports.

Eshaghi

-----Ursprungliche Nachricht-----
Von: Emmanuel Pietriga [mailto:epietriga@nuxeo.com]
Gesendet: Freitag, 07. Mai 2004 15:11
An: kianoush.eshaghi@metadat.at
Cc: www-isaviz@w3.org
Betreff: Re: Problem with the import local RDF-File


Hello,

Could you please send me one of your RDF/XML files so that I can try to
parse it and see if this error occurs here?

The error message suggests that there is an error in the SVG file
produced by GraphViz. From what I recall, there is a good chance this is
linked to your version of GraphViz. Can you tell me what version you are
using?

I remember that one of the 1.7.x or 1.8.x versions did not declare a
namespace URI for 'xlink'. But I don't remember which version exactly.
Anyway, you can try to upgrade to a more recent version (say, 1.12 or
1.10 if 1.12 is not available for your OS). You can download it from [1].

[1] http://www.research.att.com/sw/tools/graphviz/download.html

Emmanuel

--
Emmanuel Pietriga (epietriga@nuxeo.com)
http://claribole.net


Kianoush Eshaghi wrote:

> Hi,
>
> I always get the following error massage, if I try to import a local
> RDF-File (RDF/XML) in IsaViz 2.0:
>
> The parsing might not be complete (The file is probably not well-formed
> XML).
> Some nodes and edges might be missing from the graph because of an error
> (check error long) in file tmp\isv26667.svg
>
> -----Importing RDF-----
> XMLManager.parse(C:\Programme\IsaViz\tmp\isv26667.svg):
> org.xml.sax.SAXParseException: The prefix "xlink" for attribute
"xlink:href"
> is not bound.
> RDFLoader.load() java.lang.NullPointerException
> Please verify your directory preferences (GraphViz/DOT might not be
> configured properly), your default namespace and anonymous node prefix
> declarations
>
> I have checked the RDF/XML with Online-Validator (ARP)
> http://www.w3.org/RDF/Validator/, it can be parsed successfull. And I have
> looked after, whether all directory preferences are set correctly.
>
> Can some body explain me, what is matter.
>
> Cheers,
>
> Eshaghi
>
>



Received on Friday, 7 May 2004 09:53:50 GMT

This archive was generated by hypermail 2.2.0 + w3c-0.30 : Friday, 25 March 2005 11:19:57 GMT