W3C home > Mailing lists > Public > www-i18n-comments@w3.org > September 2006

Re: [Comment on ITS WD] Avoid xml:lang='he'

From: Najib Tounsi <ntounsi@emi.ac.ma>
Date: Fri, 15 Sep 2006 18:05:43 +0000
Message-ID: <450AEB77.7060901@emi.ac.ma>
To: Yves Savourel <ysavourel@translate.com>
CC: 'Richard Ishida' <ishida@w3.org>, www-i18n-comments@w3.org, public-i18n-core@w3.org, public-i18n-its@w3.org

Yves Savourel wrote:
> Mmm... The 'W3CW' appears when you use Firefox, not IE...
>
> I'm guessing this has to do with the Bidi characters I had to use to display the text correctly (since the HTML is generated from
> the XML and we can't add a *real* <span dir="rtl">.
>
> I'll try to find a solution.
>   
It seems that firefox/camino/mozilla have a strange behavior with this  
pre element
<pre>
&#x202B; &#1606;&#1588;&#1575;&#1591; 
&#1575;&#1604;&#1578;&#1583;&#1608;&#1610;&#1604; W3C
</pre>

where 2020B is a ctrl char, (RIGHT-TO-LEFT EMBEDDING here).
The texte is "Internationalization Activity" in Arabic (from your 
example 35)

A solution is to break your texte in two lines !??
<pre>
&#x202B; &#1606;&#1588;&#1575;&#1591;
&#1575;&#1604;&#1578;&#1583;&#1608;&#1610;&#1604; W3C
</pre>

Really strange.
See my example of the  bug in
http://www.w3c.org.ma/Tests/W3CW-bug.html

Regards,

Najib

-- 
Najib TOUNSI (mailto:tounsi @ w3.org)
Bureau W3C au Maroc (http://www.w3c.org.ma/)
Ecole Mohammadia d'Ingenieurs, BP 765 Agdal-RABAT Maroc (Morocco)
Phone : +212 (0) 37 68 71 50 (P1711)  Fax : +212 (0) 37 77 88 53
Mobile: +212 (0) 61 22 00 30
Received on Friday, 15 September 2006 18:03:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 October 2009 08:32:36 GMT