W3C home > Mailing lists > Public > www-forms@w3.org > September 2010

Re: invalid binding expression error

From: e-letter <inpost@gmail.com>
Date: Mon, 13 Sep 2010 21:55:52 +0100
Message-ID: <AANLkTinARdrru=L8J0sco1DQYDZ-0h_2STZNrky1HMoD@mail.gmail.com>
To: "C. M. Sperberg-McQueen" <cmsmcq@blackmesatech.com>
Cc: www-forms@w3.org
On 12/09/2010, C. M. Sperberg-McQueen <cmsmcq@blackmesatech.com> wrote:
>
> On 12 Sep 2010, at 10:54 , e-letter wrote:
>
>> On 12/09/2010, C. M. Sperberg-McQueen <cmsmcq@blackmesatech.com>
>> wrote:
>>
>>> You might try rephrasing the nodeset value to "/purpose/analysis/
>>> @type"
>>> or "analysis/@type" (if that is what you actually intend) and see if
>>> that helps at all.
>>>
>> The latter worked thank you, but I wanted the user to see the values
>> (i.e. epc england, epc scotland), not the attributes.
>
> That's a straightforward change to the XPath expression:
> /purpose/analysis/@type points to the attribute, and to
> point to the analysis element you want /purpose/analysis
> or (given that /purpose is the document element and thus
> in this case the context node) just "analysis".
>
Again, the latter suggestion works, thank you, but in truth I don't
understand this reference to the 'document element'. Could you point
to a relevant part of the specification that explains 'context node'
please?

>
>>
>> Also, the submit element does not produce the output file. Any
>> advice please?
>
> I'm not sure exactly how the Open Office forms:* attributes
> are expected to work, so my first guess is a pure speculation
> based on general principles:  your 'save' button needs, somehow,
> to be linked to a submission element.  I'm guessing that that's
> the point of the form:xforms-submission attribute.  The value
> of that attribute is "form", and I'd guess that the processor
> is looking for a submission element with an ID or name or
> label of "save".  If so, it's not finding one, since the only
> xforms:submission element in the form you showed in your
> original mail has an ID of "savepagegeneralinformation".
>

I tried to the bind element reference to 'savepagegeneralinformation'
but that failed, so removed the bind element in the submission element
as you subsequently described.

> Another possible complication is that the xforms:submission
> element in your second model has
>
>    action="file://~tmp/testsubmit.xml"
>
My typing mistake, sorry.

I looked at the output file 'testsubmit.xml' which appears as:

<?xml version="1.0"?>
<generalinformation>
							<generalinformation/>
						</generalinformation>

This seems wrong to me; I was expecting the output to contain 'epc
england' if chosen from the list menu. Am I right to conclude that
this is a bug with writer?
Received on Monday, 13 September 2010 20:56:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 10 March 2012 06:22:21 GMT