W3C home > Mailing lists > Public > www-dom@w3.org > April to June 2000

Re: Media

From: Lars Marius Garshol <larsga@garshol.priv.no>
Date: Tue, 11 Apr 2000 08:48:44 -0400 (EDT)
To: WWW DOM <www-dom@w3.org>
Message-ID: <m3og7g7qhg.fsf@lambda.garshol.priv.no>

* Blaine Brodie
| In the DOM 2 spec [07/03/2000] under section 4.2 the MediaList
| interface has a method called "delete".  Since delete is a keyword
| in C++, perhaps this method should be named "deleteMedium" instead.

* Philippe Le Hegaret
| Hum, seems we really need to change the name of this method.

Unless I am much mistaken, the IDL -> C++ mapping defined by the OMG
deals with this by renaming the method in some systematic way, such as
by adding an underscore prefix or something.

So this is necessarily catastrophic, although it probably violates the
principle of least surprise.

--Lars M.
Received on Tuesday, 11 April 2000 09:16:26 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:06 UTC