W3C home > Mailing lists > Public > www-dom@w3.org > April to June 2000

Re: Media

From: Philippe Le Hegaret <plh@w3.org>
Date: Mon, 10 Apr 2000 14:51:00 -0400
Message-ID: <38F22294.23DDC2AB@w3.org>
To: WWW DOM <www-dom@w3.org>
Blaine Brodie wrote:
> In the DOM 2 spec [07/03/2000] under section 4.2 the MediaList interface
> has a method called "delete".  Since delete is a keyword in C++, perhaps
> this method should be named "deleteMedium" instead.
Hum, seems we really need to change the name of this method.
It makes sense to rename append for consistency. Here is
the new interface :

// Introduced in DOM Level 2:
interface MediaList {
  attribute DOMString        mediaText;
          // raises(DOMException) on setting

 readonly attribute unsigned long    length;
 DOMString         item(in unsigned long index);
 void              deleteMedium(in DOMString oldMedium)
 void              appendMedium(in DOMString newMedium)

Received on Monday, 10 April 2000 14:51:01 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:06 UTC