W3C home > Mailing lists > Public > www-dom-ts@w3.org > February 2002

Re: Documentation and DOMTSL1Core.zip

From: Dimitris Dimitriadis <dimitris@ontologicon.com>
Date: Mon, 11 Feb 2002 18:47:05 +0100
Cc: www-dom-ts@w3.org
To: Philippe Le Hegaret <plh@w3.org>
Message-Id: <5CA64BB4-1F17-11D6-8164-000393556882@ontologicon.com>
comments inlined

I'll update the sidtro so that it contains stylesheets, pictures and so 
forth, even though I think the IPR disclaimer should point to W3C, 
especially sine a verbatim is provided in the matrix. For the rest:

On Monday, February 11, 2002, at 04:46 , Philippe Le Hegaret wrote:

> I started to test the package with my newbie mode and here is some
> comments:
>
> The zipfile does not create its own directory. would be nice if the
> package unzip in a directory such as "DOML1Core-20020206". It is
> important imo to use the date as a version number.
>
> correct the link to NIST logo.
> Copy the W3C Icon (instead of link to the web site)
>
> copy activity-home.css and toc.js (instead of a link to the web site)
>
>
> Overview
> provide a link to http://www.w3.org/DOM/Test on the text "DOM
> Conformance Test Suite"
>
[dd] I'll add a section saying that the TS is produced in accordance 
with the Process docuemtn and point to it from there.

> Running the ECMA tests
> - I tried to run alltest.html but it did nothing. Seems to be at least
> the same error as Jason (I use mozilla 0.9.8)
>  So I applied the patch from Curt and it worked:
> Runs:
> 290
> Errors:
> 63
> Failures:
> 25
>
> I got 3/4 javascript warnings in the console but it worked.
>
>
> Running the Java tests:
>
> - add "junit-run.jar is in dist/"
>   (java -jar dist/junit-run.jar)
>
> - if I run java -jar junit-run.jar in dist/, the program output:
>  Exception in thread "main" java.lang.NoClassDefFoundError:
> org/w3c/dom/DOMImplementation
>
>   move the sentence "The parser must be put in the dist directory"
>  before the command line.
>
> - Once I got the interface, I don't see anything to select. If I put
> org.w3c.domts.level1.core.TestXerces or ...AltConfig, it keeps saying
> "failed to invoke suite():java.lang.NoSuchMethodError". I do have
> xerces.jar in dist/ ...
>  I looked into dom1-core.jar and this class doesn't seem to exist?
>
>
> Copyight: (s/Copyight/Copyright)
>
> please provide a link to
> http://www.w3.org/Consortium/Legal/copyright-software-19980720
> a copy of this file in the package? (similar to the one included
> in the DOM specs packages)
>
> missing section "How to contribute"?
>
[dd] I left this out on purpose since it is a distribution with source 
files; i could include relevant info in the main page with appropriate 
links

>
Received on Monday, 11 February 2002 12:46:15 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:34:04 UTC