W3C home > Mailing lists > Public > www-dom-ts@w3.org > February 2002

Documentation and DOMTSL1Core.zip

From: Philippe Le Hegaret <plh@w3.org>
Date: 11 Feb 2002 10:46:00 -0500
To: Dimitris Dimitriadis <dimitris@ontologicon.com>
Cc: www-dom-ts@w3.org
Message-Id: <1013442361.25718.43.camel@jfouffa>
I started to test the package with my newbie mode and here is some
comments:

The zipfile does not create its own directory. would be nice if the
package unzip in a directory such as "DOML1Core-20020206". It is
important imo to use the date as a version number.

correct the link to NIST logo.
Copy the W3C Icon (instead of link to the web site)

copy activity-home.css and toc.js (instead of a link to the web site)


Overview
provide a link to http://www.w3.org/DOM/Test on the text "DOM
Conformance Test Suite"

Running the ECMA tests
- I tried to run alltest.html but it did nothing. Seems to be at least
the same error as Jason (I use mozilla 0.9.8)
 So I applied the patch from Curt and it worked:
Runs:
290
Errors:
63
Failures:
25

I got 3/4 javascript warnings in the console but it worked.


Running the Java tests:

- add "junit-run.jar is in dist/"
  (java -jar dist/junit-run.jar)

- if I run java -jar junit-run.jar in dist/, the program output:
 Exception in thread "main" java.lang.NoClassDefFoundError:
org/w3c/dom/DOMImplementation

  move the sentence "The parser must be put in the dist directory"
 before the command line.

- Once I got the interface, I don't see anything to select. If I put
org.w3c.domts.level1.core.TestXerces or ...AltConfig, it keeps saying
"failed to invoke suite():java.lang.NoSuchMethodError". I do have
xerces.jar in dist/ ...
 I looked into dom1-core.jar and this class doesn't seem to exist?


Copyight: (s/Copyight/Copyright)

please provide a link to
http://www.w3.org/Consortium/Legal/copyright-software-19980720
a copy of this file in the package? (similar to the one included
in the DOM specs packages)

missing section "How to contribute"?
Received on Monday, 11 February 2002 10:46:10 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:34:04 UTC