W3C home > Mailing lists > Public > www-dom-ts@w3.org > April 2002

Fw: Testcase attrcreatetextnode2.xml in level1/core does not exercise the test

From: Curt Arnold <carnold@houston.rr.com>
Date: Sun, 21 Apr 2002 18:29:36 -0500
Message-ID: <005001c1e98c$66b0a370$a800a8c0@CurtMicron>
To: <www-dom-ts@w3.org>
I've added a attrcreatetextnode3 and 4 that should come closer to the stated
intent of the the test and modified the descriptions for attrcreatetextnode
and attrcreatetextnode2.

----- Original Message -----
From: "Curt Arnold" <carnold@houston.rr.com>
To: "Nick Efthymiou" <NEFTH@pacbell.net>
Sent: Saturday, April 20, 2002 11:05 AM
Subject: Re: Testcase attrcreatetextnode2.xml in level1/core does not
exercise the test


> I went back and checked earlier sources and that seems to have been
brought
> over from the original NIST tests.  Definitely the actual test doesn't
> exercise the intent, not only is the semi-colon missing but it uses a %
> instead of a &.
>
> I think the right thing to do is to change the description and admit that
> the test isn't doing what it should be doing and to add additional tests
> that might actually trigger the potentially flawed behavior.
>
> Was there a reason this message was sent off-list?  Could you resent this
or
> the original message to the mailing list to get it in the official record?
>
> ----- Original Message -----
> From: "Nick Efthymiou" <NEFTH@pacbell.net>
> To: <carnold@houston.rr.com>
> Sent: Saturday, April 20, 2002 2:59 AM
> Subject: Testcase attrcreatetextnode2.xml in level1/core does not exercise
> the test
>
>
> >
> > Please review
> >
>
http://dev.w3.org/cvsweb/2001/DOM-Test-Suite/tests/level1/core/attrcreatetex
> > tnode2.xml?annotate=1.2
> >
> > Line 22 states the intention of the test:
> > 22:   child of of the fourth employee and assign the "Y%ent1;"
> >
> > Line 44 sets the value as follows (note missing ";"):
> > 44: <nodeValue obj="streetAttr" value='"Y%ent1"'/>
> >
> > Since no entity is set, the test case does not test what it is intended
> to.
> >
> > The same bug (test does not exercise what is intended) is apparently
also
> > true with attrcreatetextnode:
> >
>
http://dev.w3.org/cvsweb/2001/DOM-Test-Suite/tests/level1/core/attrcreatetex
> > tnode.xml?annotate=1.7
> >
> > Same line numbers (22 vs. 44).
> >
> > Regards,
> >
> > - Nick -
> >
> >
> >
> >
>
Received on Sunday, 21 April 2002 19:29:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 6 April 2009 12:58:46 GMT