W3C home > Mailing lists > Public > www-amaya@w3.org > October to December 1997

Bug in Amaya V1.1a Beta on LINUX-ELF -- keyboard?

From: Simon Brooke <simon@jasmine.org.uk>
Date: Fri, 24 Oct 1997 14:23:38 +0100
Message-Id: <9710241423.ZM31002@caleddon.jasmine.org.uk>
To: www-amaya@w3.org
Hi

I'm not sure whether this is a bug or a misconfiguration, but whichever
I'm not managing to correct it; which is a pity because Amaya (when it
works) is really nice and useful.

The problem is this: most times, when Amaya starts, the following keys on
the keyboard don't work at all:

<return>
<enter> on keypad
<delete>
<backspace>

The following behave very oddly:

numeral 2 shows as '@' (alpha)
numeral 7 shows as '{' (open curly bracket)
numeral 8 shows as '[' (open square bracket)
numeral 9 shows as ']' (close square bracket)
numeral 0 shows as '}' (close curly bracket)
<hyphen> shows as '\' (backslash), as does <underscore>
<equals> shows as '+' (plus)
<right curly bracket> shows as '~' (tilde) as does <right square bracket>

In addition the <shift> key doesn't work for any letter, but does work
for some symbols and numeral keys.

This is frustrating, but what makes it worse is that occasionally it
works perfectly. Two obvious potential causes were

/usr/local/Thot/config/XKeysymDB	and
/usr/local/Thot/config/amaya.keyboard

I've tried removing both of these, but it hasn't helped; Amaya still
starts, and the keyboard still doesn't work.

My /usr/X11R6/lib/X11/XKeysymDB is extremely similar to that which is
distributed with Netscape 3; the only patch I make to this is:

xmodmap -e 'keycode  22 = BackSpace'



-- 
simon@jasmine.org.uk (Simon Brooke) http://www.jasmine.org.uk/~simon

		;; Semper in faecibus sumus, sole profundum variat.
Received on Friday, 24 October 1997 10:27:19 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:30 UTC