W3C home > Mailing lists > Public > w3c-wai-ig@w3.org > April to June 2000

RE: Seeking guidance...

From: Bruce Bailey <bbailey@clark.net>
Date: Fri, 7 Apr 2000 15:00:05 -0400
To: <w3c-wai-ig@w3.org>, <kasday@acm.org>, <jpledger@mindspring.com>
Cc: "Charles McCathieNevile" <charles@w3.org>, "Marjolein Katsma" <access@javawoman.com>
Message-ID: <000c01bfa0c3$7c47a440$53fe330a@msde>
> You can use the mouse to decide if you want to give focus to a form input,
> but it doesn't really work for a link or button - there is an ill-defined
> notion of how to focus on these with a mouse, but in practice
> mouseovers are interpreted as focus (more or less).

This is what I am talking about!  onMouseOver IS (to my way of thinking) a
pointer-oriented version of onFocus.  The way onFocus has been interpreted
(again, from a pointer-oriented perspective) is as an onClick.  This is
WRONG.  The device-neutral equivalent for this might be "onSelect" -- quite
a different animal!

No, you can't tell where the user's eye is actually reading.  onMouseOver is
a fair attempt at making a guess and the result is usually non-obtrusive and
requires minimal effort on the part of the user.  BUT it is only good for
folks who are by both ability and inclination pointer oriented.  There
SHOULD be some workable keyboard-oriented equivalent, but based on this
discussion, I must conclude that there is not!  Even better, would be
device-neutral equivalent, but apparently the rather easy case of a
visually-oriented-but-keyboard-avoiding surfer (there of plenty of them)
isn't even adequately addressed!

onFocus SHOULD support any keyboard-oriented user (sighted or not) -- but it
also should be a REPLACEMENT for pointer-oriented attributes that are in
common use now.  onMouseOver is EXTREMELY popular (much more so than
onClick).  Better yet, there would be a device-neutral attribute that
supported BOTH mouse and keyboard (since onFocus ain't it).  IMHO the
current definition of onFocus is BROKEN and gets us NOTHING.  No harm with
including it, but why advocate for it and not a mythical element like
onProximity or whenFocusIsNearby ???

Having ranted, let me attempt amends by attempting a summary:
As a matter of actual practice, one could (and should) duplicate onMouseOver
attribute content with onFocus (TABINDEX might have to be added too).
Anyone who complains about their code becoming invalid should be excused
from this requirement.

Len -- how about adding this to the WAVE?

For what it's worth, AbleTV.net (which got me started in this thread)
doesn't have to worry about onFocus making their code invalid!  SMILE.  I
hate recommending code duplication, but I don't see a way around it.
Received on Friday, 7 April 2000 15:03:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 19 July 2011 18:13:48 GMT