W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > October 2002

Re: RDF Core WG draft of RDF/XML Syntax Specification (Revised) for review

From: Dave Beckett <dave.beckett@bristol.ac.uk>
Date: Mon, 28 Oct 2002 22:07:26 +0000
To: pat hayes <phayes@ai.uwf.edu>
cc: w3c-rdfcore-wg@w3.org, Daniel Krech <eikeon@eikeon.com>
Message-ID: <29307.1035842846@hoth.ilrt.bris.ac.uk>

>>>pat hayes said:
> >  >>>Daniel Krech said:
> >  > Hi Dave,
> >>
> >
> >>  ... If not,
> >>  then why not define the productions with anyURI in them as follows:
> >>
> >>      nodeElementURIs = rdf:Description | classURI | rdf:nil | anyURI
> >>                        except from the RDF namespace
> >>
> >>      propertyElementURIs = rdf:li | propertyURI | anyURI except from
> >>                            the RDF namespace
> >>
> >>      propertyAttributeURIs = anyURI except from the RDF namespace
> >>
> >>    where:
> >>
> >>      classURIs = SEQ | BAG | ALT | STATEMENT | PROPERTY | LIST
> >>
> >>      propertyURIs = SUBJECT | PREDICATE | OBJECT | TYPE | VALUE | FIRST
> >>                     | REST | _n
> >
> >
> >I do like the classURIs & propertyURIs split and will consider this.
> >Particularly I like it if it matches the namespace split too in 5.1.
> 
> Whoa!! Am I following this right? Do we now have a syntactic 
> distinction between property URIs and Class URIs? If so, I protest 
> strongly. There should be no such syntactic distinction in RDF.  This 
> will break RDFS.


No, you are not reading it right and it was just a suggestion.

Firstly, I wasn't going to use it exactly as Daniel suggested, but
was instead thinking of using this to break down the longer list I
had:

  7.2.2 syntaxTerms           := rdf:RDF | rdf:ID | rdf:about | rdf:bagID | rdf:parseType | rdf:resource | rdf:nodeID | rdf:datatype
  7.2.3 nodeElementURIs       := anyURI - ( syntaxTerms | rdf:li )
  7.2.4 propertyElementURIs   := anyURI - ( syntaxTerms | rdf:Description | rdf:nil)
  7.2.5 propertyAttributeURIs := anyURI - ( syntaxTerms | rdf:Description | rdf:li | rdf:nil)

into something that matched more accurately the description we've had
for months, of the terms in the RDF namespace section 5.1:

  http://ilrt.org/discovery/2001/07/rdf-syntax-grammar/#section-Namespace

which consists of syntax terms, classes, properties and resources.


> When was this decision taken??

The syntax document has had the namespace terms split in the draft
for months and as I recall was done after we discussed how to present the
RDF namespace it was felt that 5.1
  http://ilrt.org/discovery/2001/07/rdf-syntax-grammar/#section-Namespace
was easier to explain betwen syntax terms and other things by
separating them out; like rdf:datatype is a syntax thing (will not
appear in the schema) and rdf:Seq will.


--

The above terms Daniel was describing were never used alone in his
form, merely to explain where rdf-namespaced terms were allowed.

For example, classURIs was never be used on its own, Daniel proposed:

     nodeElementURIs = rdf:Description | classURI | rdf:nil | anyURI
                       except from the RDF namespace

and although I wasn't quite agreeing with that, you could *not* tell
anything about any particular term (which is an XML element) apart
from whether it was legal to use at that point in the XML syntax.

--

On further consideration, I'm not going to what Daniel asks, but will
modify syntaxTerms, since it is misnamed - it doesn't contain all the
terms that are syntax only (it leaves out rdf:Description and rdf:li) -
and add a new grammar term.

Dave
Received on Monday, 28 October 2002 17:09:29 EST

This archive was generated by hypermail pre-2.1.9 : Wednesday, 3 September 2003 09:52:32 EDT