W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > November 2001

Re: closing semantic issues

From: Peter F. Patel-Schneider <pfps@research.bell-labs.com>
Date: Mon, 05 Nov 2001 14:03:43 -0500
To: danbri@w3.org
Cc: phayes@ai.uwf.edu, w3c-rdfcore-wg@w3.org
Message-Id: <20011105140343X.pfps@research.bell-labs.com>
From: Dan Brickley <danbri@w3.org>
Subject: Re: closing semantic issues
Date: Mon, 5 Nov 2001 13:53:24 -0500 (EST)

> On Mon, 5 Nov 2001, Peter F. Patel-Schneider wrote:
> 
> > From: Pat Hayes <phayes@ai.uwf.edu>
> > Subject: Re: closing semantic issues
> > Date: Mon, 5 Nov 2001 12:13:46 -0600
> >
> > [...]
> >
> > > >  In particular, rdf:Bag is not a bag
> > > >at all, but instead is much more like a sequence.
> > >
> > > Right, and that is exactly how the M&S so describes it, by insisting
> > > that :_1, :_2 and so on apply to *all* containers. It would be easy
> > > to change the MT to describe a different notion than rdf:Bag, but
> > > then it would not in fact describe RDF.
> > >
> > > >  If rdf is going to have
> > > >something called rdf:Bag, then its *RDF* semantics should conform to the
> > > >intended meaning of bags!
> > >
> > > Its model theory should conform to its intended meaning, but if that
> > > intended meaning is not in conformity with a broader notion of 'bag',
> > > then don't blame the model theory.  What you are complaining about
> > > here is an issue in how RDF should treat containers, but its not a
> > > model theory issue.
> >
> > I'm not blaming the model theory at all here.  However, I am blaming the
> > ``theory'' of rdf:Bag as expressed in M&S.
> >
> > Let me restate my objection then:
> >
> > If RDF is going to have something called rdf:Bag, then its *RDF* semantics
> > should conform to the generally-accepted meaning of bags, and not to some
> > other meaning.  If the RDF semantics of this thing do not conform to the
> > generally-accepted meaning of bags then it should be given a different
> > name.
> 
> [thinks....]
> 
> One way we could do this would be to define a super-property(*) of the RDF
> container membership properties (rdf:_1, rdf:_2, rdf:_n). Hmm, not sure
> that this delivers exactly what you ask for, but it feels close. I've had
> in mind that this would be useful for other purposes too, for example in
> RDF/SW apps that need to express queries about containers and their members.
> 
> Dan
> 
> 
> [*] eg called 'rdf:member','rdf:li' etc.
> 

This works, if you get rid of the _n properties.

It doesn't help to have a relationship between an rdf:Bag and its
``members'' called, say, 'rdf:member', as long as you still have rdf:_1,
etc. (either explicitly in the input or implicitly).

The whole point, as Dan Connolly pointed out, is that 

	<rdf:Bag>
	   <rdf:_1>1</rdf:1> 
	   <rdf:_2>2</rdf:2> 
	<rdf:Bag>

and 

	<rdf:Bag>
	   <rdf:_2>1</rdf:2> 
	   <rdf:_1>2</rdf:1> 
	<rdf:Bag>

should be equivalent, that is, a proto-bag that contains (at least) the
integers 1 and 2, both with at least single multiplicity.

Of course, getting rid of _n still leaves open the strange aspect that you
can't ``close'' a bag, but this could be made to work.

peter
Received on Monday, 5 November 2001 14:05:22 EST

This archive was generated by hypermail pre-2.1.9 : Wednesday, 3 September 2003 09:42:30 EDT