W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > November 2001

Re: closing semantic issues

From: Dan Brickley <danbri@w3.org>
Date: Mon, 5 Nov 2001 13:53:24 -0500 (EST)
To: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>
cc: <phayes@ai.uwf.edu>, <w3c-rdfcore-wg@w3.org>
Message-ID: <Pine.LNX.4.30.0111051347140.5351-100000@tux.w3.org>
On Mon, 5 Nov 2001, Peter F. Patel-Schneider wrote:

> From: Pat Hayes <phayes@ai.uwf.edu>
> Subject: Re: closing semantic issues
> Date: Mon, 5 Nov 2001 12:13:46 -0600
> [...]
> > >  In particular, rdf:Bag is not a bag
> > >at all, but instead is much more like a sequence.
> >
> > Right, and that is exactly how the M&S so describes it, by insisting
> > that :_1, :_2 and so on apply to *all* containers. It would be easy
> > to change the MT to describe a different notion than rdf:Bag, but
> > then it would not in fact describe RDF.
> >
> > >  If rdf is going to have
> > >something called rdf:Bag, then its *RDF* semantics should conform to the
> > >intended meaning of bags!
> >
> > Its model theory should conform to its intended meaning, but if that
> > intended meaning is not in conformity with a broader notion of 'bag',
> > then don't blame the model theory.  What you are complaining about
> > here is an issue in how RDF should treat containers, but its not a
> > model theory issue.
> I'm not blaming the model theory at all here.  However, I am blaming the
> ``theory'' of rdf:Bag as expressed in M&S.
> Let me restate my objection then:
> If RDF is going to have something called rdf:Bag, then its *RDF* semantics
> should conform to the generally-accepted meaning of bags, and not to some
> other meaning.  If the RDF semantics of this thing do not conform to the
> generally-accepted meaning of bags then it should be given a different
> name.


One way we could do this would be to define a super-property(*) of the RDF
container membership properties (rdf:_1, rdf:_2, rdf:_n). Hmm, not sure
that this delivers exactly what you ask for, but it feels close. I've had
in mind that this would be useful for other purposes too, for example in
RDF/SW apps that need to express queries about containers and their members.


[*] eg called 'rdf:member','rdf:li' etc.
Received on Monday, 5 November 2001 13:53:30 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:53:53 UTC