W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > November 2009

Re: exclude-inline-prefixes question

From: Innovimax W3C <innovimax+w3c@gmail.com>
Date: Tue, 10 Nov 2009 14:54:16 +0100
Message-ID: <546c6c1c0911100554k48588e2fsd6a7dd61c8ea9175@mail.gmail.com>
To: Toman_Vojtech@emc.com
Cc: public-xml-processing-model-wg@w3.org
Well this time, I agree :)
This test should fail to my understanding

I think that the error should be err:XD0001

Mohamed
On Tue, Nov 10, 2009 at 12:14 PM, <Toman_Vojtech@emc.com> wrote:
>
> I am not sure that the tests exclude-inline-prefixes #006 and #007 are
> actually correct. For example, this is what the test #006 does:
>
> <p:identity>
> <p:input port="source" xmlns:test="http://www.test.com">
>  <p:inline exclude-inline-prefixes="test"><test:doc/></p:inline>
> </p:input>
> </p:identity>
>
> The test expects this to succeed, but because the namespace bound to
> "test" is explicitly excluded, shouldn't the processor fail when it
> encounters <test:doc/>?
>
> If this is indeed the case and the processor should fail, what error
> should it report?
>
> (Sorry if I just got confused.)
>
> Regards,
> Vojtech
>



--
Innovimax SARL
Consulting, Training & XML Development
9, impasse des Orteaux
75020 Paris
Tel : +33 9 52 475787
Fax : +33 1 4356 1746
http://www.innovimax.fr
RCS Paris 488.018.631
SARL au capital de 10.000 
Received on Tuesday, 10 November 2009 13:54:57 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 10 November 2009 13:54:57 GMT