W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > March 2007

Re: viewport-source and iteration-source element names

From: Alex Milowski <alex@milowski.org>
Date: Mon, 12 Mar 2007 08:10:06 -0700
Message-ID: <28d56ece0703120810o31006875u1561f5092b2c060a@mail.gmail.com>
To: public-xml-processing-model-wg@w3.org
On 3/12/07, Norman Walsh <Norman.Walsh@sun.com> wrote:
>
> / Jeni Tennison <jeni@jenitennison.com> was heard to say:
> | Alex Milowski wrote:
> |> I think it would be nice to rename 'viewport-source' and
> |> 'iteration-source' to
> |> just a plain 'source' element.  The 'source' element specifies an input
> |> where the context (or port) is assumed ( e.g. the target of the
> viewporting
> |> or iteration).
> |
> | I agree.
>
> So you'd both prefer "source" on viewport and for-each but
> "xpath-context" on choose/when?


I hadn't considered 'xpath-context'.  I'd prefer that to be 'source'
as well.




-- 
--Alex Milowski
"The excellence of grammar as a guide is proportional to the paucity of the
inflexions, i.e. to the degree of analysis effected by the language
considered."

Bertrand Russell in a footnote of Principles of Mathematics
Received on Monday, 12 March 2007 15:10:13 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:21:50 GMT