W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > March 2007

Re: viewport-source and iteration-source element names

From: Norman Walsh <Norman.Walsh@Sun.COM>
Date: Mon, 12 Mar 2007 10:38:06 -0400
To: public-xml-processing-model-wg@w3.org
Message-ID: <87tzwqr0hd.fsf@nwalsh.com>
/ Jeni Tennison <jeni@jenitennison.com> was heard to say:
| Alex Milowski wrote:
|> I think it would be nice to rename 'viewport-source' and
|> 'iteration-source' to
|> just a plain 'source' element.  The 'source' element specifies an input
|> where the context (or port) is assumed ( e.g. the target of the viewporting
|> or iteration).
| I agree.

So you'd both prefer "source" on viewport and for-each but
"xpath-context" on choose/when?

If that's what the group wants, I'm not going to stand in the way, but
there's a part of me that thinks it would be better for all three to
be the same or all three to be different.

In other wordes iteration-source, for-each-source, and xpath-context
or "source" in all three places.

(I had considered suggesting source in all three places myself, but
decided not to bother in the interest of getting to Last Call.)

                                        Be seeing you,

Norman Walsh
XML Standards Architect
Sun Microsystems, Inc.

Received on Monday, 12 March 2007 14:38:17 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:32:42 UTC