W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > April 2007

Re: Component proposals

From: Jeni Tennison <jeni@jenitennison.com>
Date: Tue, 24 Apr 2007 19:31:06 +0100
Message-ID: <462E4CEA.9070001@jenitennison.com>
To: public-xml-processing-model-wg@w3.org

Norman Walsh wrote:
> I propose that we rename p:serialize to p:escape-markup and
> p:parse to p:unescape-markup.


> I propose that we add an optional p:serialize component that
> implements XSLT 2.0/XQuery 1.0 Serialization.
> I propose that we rename p:store to p:save and describe it as
> implementing XSLT 1.0 Serialization.

I assume that p:store currently doesn't do HTTP PUT, and that the URIs 
must be relative or use the file:// scheme? If so, then changing its 
name to p:save is OK by me. If not (i.e. the implementation is free to 
attempt to store the document through whatever method is appropriate), 
then the more generic name is better.

I'm not keen on having p:save do XSLT 1.0 serialisation and p:serialize 
do XSLT 2.0/XQuery 1.0 serialisation. The names should make it clear 
that they do the same thing just have different sets of options. So 
p:save(1) and p:save2 would be better IMO.

Jeni Tennison
Received on Tuesday, 24 April 2007 18:31:09 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:32:42 UTC