W3C home > Mailing lists > Public > public-ws-desc-comments@w3.org > October 2006

RE: Suggestion to change {safety} to {safe}

From: Jonathan Marsh <jonathan@wso2.com>
Date: Mon, 16 Oct 2006 10:33:24 -0700
To: "'John Kaputin \(gmail\)'" <jakaputin@gmail.com>
Cc: <woden-dev@ws.apache.org>, <public-ws-desc-comments@w3.org>
Message-ID: <005501c6f149$2ffb9000$3901a8c0@DELLICIOUS>
Thanks for your comment.  The WS Description Working Group tracked this
issue as a CR058 [1].

 

The Working Group accepted your proposal, and renamed this property in the
latest editor's draft [2].

 

Unless you let us know otherwise by the end of October, we will assume you
agree with the resolution of this issue.

 

[1] http://www.w3.org/2002/ws/desc/5/cr-issues/issues.html#CR058

[2]
http://dev.w3.org/cvsweb/~checkout~/2002/ws/desc/wsdl20/wsdl20-adjuncts.html
?content-type=text/html;%20charset=utf-8#safety-decl-relate

 

Jonathan Marsh -  <http://www.wso2.com> http://www.wso2.com -
<http://auburnmarshes.spaces.live.com> http://auburnmarshes.spaces.live.com

 

  _____  

From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org] On
Behalf Of John Kaputin (gmail)
Sent: Wednesday, May 24, 2006 2:44 PM
To: www-ws-desc@w3.org
Cc: woden-dev@ws.apache.org
Subject: Suggestion to change {safety} to {safe}

 

A bit late in the day (sorry), but I'd like to suggest renaming the
extension property {safety} to {safe} to better describe one of the binary
states (safe vs unsafe) of this property, which in turn will map neatly to a
boolean API method like isSafe(). It also reflects the discussion of this
property in the spec which talks about operations being 'safe' or 'unsafe'.
getSafety() is cumbersome and isSafety() doesn't sound quite right.

As an example, the {required} boolean property describes a binary state
(required vs not required) that maps neatly to the boolean method
isRequired().

Our options in Woden are to just adopt the isXXX() convention for a boolean
property {XXX} and not worry about how it sounds or diverge from the exact
property-to-method naming convention we have been using and construct a more
suitable boolean method name (i.e. for the boolean properties {http cookies}
and {http location ignore uncited}).

regards,
John Kaputin.
Received on Monday, 16 October 2006 17:38:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:20:32 GMT