W3C home > Mailing lists > Public > public-ws-addressing-tests@w3.org > March 2006

RE: Saturday Morning, 4th March

From: Jonathan Marsh <jmarsh@microsoft.com>
Date: Sat, 4 Mar 2006 15:46:54 -0800
Message-ID: <37D0366A39A9044286B2783EB4C3C4E801CF85B1@RED-MSG-10.redmond.corp.microsoft.com>
To: "Mark Little" <mark.little@jboss.com>, <paul.downey@bt.com>
Cc: <dims@wso2.com>, <Arun.Gupta@Sun.COM>, <public-ws-addressing-tests@w3.org>

Right now the test harness expects one log file per column (e.g.
jboss->msft).  We can either add a step to the processing that combines
the log files into a single "test pass" in the test suite (I can work on
that, but it might not be until Tuesday), or perhaps you could perform a
merge prior to posting them.

In the meantime, I'm adding the logs to show the results (even though
they aren't tallied up in one nice neat column.)

Congratulations on a very greenish pass!  Looks like only 5 or 6
testcases need attention!

> -----Original Message-----
> From: Mark Little [mailto:mark.little@jboss.com]
> Sent: Saturday, March 04, 2006 10:09 AM
> To: paul.downey@bt.com
> Cc: dims@wso2.com; Arun.Gupta@Sun.COM; Jonathan Marsh; public-ws-
> addressing-tests@w3.org
> Subject: Re: Saturday Morning, 4th March
> 
> Paul, I take it these ...
> 
> http://213.162.124.157:8080/interop/logs/jboss-msft-1.1.xml
> http://213.162.124.157:8080/interop/logs/jboss-msft-1.2.xml
> http://213.162.124.157:8080/interop/logs/jboss-msft-1150.xml
> http://213.162.124.157:8080/interop/logs/jboss-msft-1152.xml
> 
> http://213.162.124.157:8080/interop/logs/jboss-sun-1.1.xml
> http://213.162.124.157:8080/interop/logs/jboss-sun-1.2.xml
> 
> don't help because of the "vi problem" too? If not, let me know and
I'll
> see what I can do at my end, as Kevin is unavailable.
> 
> Mark.
> 
> 
> 
> paul.downey@bt.com wrote:
> > show me the URIs!
> >
> > -----Original Message-----
> > From: Mark Little [mailto:mark.little@jboss.com]
> > Sent: Sat 3/4/2006 12:36 PM
> > To: dims@wso2.com
> > Cc: Downey,P,Paul,CXMA C; Arun.Gupta@Sun.COM; jmarsh@microsoft.com;
> public-ws-addressing-tests@w3.org
> > Subject: Re: Saturday Morning, 4th March
> >
> > No JBoss-to-IBM, JBoss-to-JBoss, JBoss-to-MSFT or JBoss-to-WSO2
either
> :-(
> >
> > Mark.
> >
> >
> > Davanum Srinivas wrote:
> >
> >> -----BEGIN PGP SIGNED MESSAGE-----
> >> Hash: SHA1
> >>
> >> Paul,
> >>
> >> IBM->WSO2 is missing from the matrix? I'll send an update today for
the
> bad stuff. Yes, i will send a url :)
> >>
> >> thanks,
> >> dims
> >>
> >> Mark Little wrote:
> >>
> >>
> >>> Hi Paul. Comments inline.
> >>>
> >>> paul.downey@bt.com wrote:
> >>>
> >>>
> >>>> Arun, All,
> >>>>
> >>>> I've been periodically slurping the logs down from people's
servers,
> >>>> in as friendly US timezone as my need to sleep allowed :)
> >>>>
> >>>> It takes special manual effort to processs logs sent by Email,
and
> >>>> we've seen a bunch of these sent this week during the F2F.
> >>>> It's therefore possible regression may have been introduced on
both
> >>>> the actor and observer sides of the shop :)
> >>>>
> >>>> - I can't access the JBoss server (I get a timeout), and looking
> >>>> at the attachments see we have to assemble them into the single
> >>>> log file the report expects for each interaction?
> >>>>
> >>>>
> >>>>
> >>> Apologies, as we thought we were adhering to the required log
format.
> >>> Can you point me in the right direction and we'll change asap?
> >>>
> >>>
> >>>> Still no log server from WSO2, that would be very helpful.
> >>>>
> >>>> So really it's not been ideal for us to work on this, this week,
> >>>> but maybe we can all pull it together during next week.
> >>>>
> >>>> *IMPORTANT NOTICE*
> >>>> As the matrix is now getting large, and time is running out,
Jonathan
> >>>> and I have decided we can no longer accommodate ad-hoc log files
sent
> >>>> in ad-hoc ways and formats - you need to provide a log directory
on a
> >>>> web site with one log file per interaction to all the other
parties
> >>>> in either WS-I or our own format to make it onto the report.
> >>>>
> >>>>
> >>> Shouldn't be a problem if you can provide the reference.
> >>>
> >>>
> >>>> *IMPORTANT NOTICE*
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>> And also the WS-I monitor changes the wsa:To header which the
> >>>>> Microsoft stack does not seem to like. I'll try to make these
> changes
> >>>>> over the weekend and send updated logs.
> >>>>>
> >>>>>
> >>>>>
> >>>> bizare!
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>> test1152 and 1252 still needs to be fixed in the CVS repository.
> They
> >>>>> are still checking for 4 messages whereas they should only be 2.
> >>>>>
> >>>>>
> >>>>>
> >>>> we've been working on that - David had a fix which we've added:
> >>>> http://lists.w3.org/Archives/Public/public-ws-addressing-
> tests/2006Mar/0029.html
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>> I cant meet tuesday morning since I'll be travelling tuesday
through
> >>>>> thursday. I can do monday or friday morning instead.
> >>>>>
> >>>>>
> >>>>>
> >>>> Monday and friday evenings aren't great for me, but I've
> >>>> been working with Jonathan so as not to become "the weakest link"
> >>>> and so together we can cover 2/3rs of the timezones :)
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>> Can you please regenerate the report by picking up the logs for
> >>>>> Sun->Sun, Sun->IBM, Sun->Axis, Sun->JBoss from [1] ? This will
give
> a
> >>>>> better idea of the current status.
> >>>>>
> >>>>>
> >>>>>
> >>>> have been doing so, Arun, maybe you'd like to add WSO2 to your
> matrix,
> >>>> and refresh the Microsoft log, it's as old as the hills:
> >>>>
> >>>>    Sun-Microsoft.xml     86.9 kb     Thu, 19 Jan 2006 03:25:08
GMT
> >>>>
> >>>> [1] http://soapinterop.java.sun.com:8080/wsalogs/.
> >>>>
> >>>> Can everyone please try to add logs for all other endpoints:
> >>>>
> >>>> http://www.w3.org/2002/ws/addr/testsuite/endpoints/
> >>>>
> >>>> State of play after our hack this morning:
> >>>>
> >>>> http://www.w3.org/2002/ws/addr/testsuite/report/
> >>>>
> >>>> still getting problems with lots of white boxes in the Sun
columns,
> >>>> can't reach the JBoss log file server
> >>>>
> >>>>
> >>> That should be up soon.
> >>>
> >>>
> >>>>  and I'm still getting bad prefix 'echo' from some of the WSO2
log
> >>>> files  which
> >>>> breaks the processor and now makes their column all 'bad'.
> >>>>
> >>>>
> >>>>
> >>> Mark.
> >>>
> >>>
> >>>> Paul
> >>>>
> >>>>
> >>>>
> >>>>
> >>>
> >>>
> >> - --
> >> Davanum Srinivas (dims@wso2.com)
> >> VP/Engg, WSO2 (http://wso2.com)
> >> Yahoo IM: dims Cell/Mobile: +1 (508) 415 7509
> >> -----BEGIN PGP SIGNATURE-----
> >> Version: GnuPG v1.4.1 (Cygwin)
> >>
> >> iD8DBQFECXzQgNg6eWEDv1kRAu83AKCdCu/sgztyFURb6G+7Y4psvdwEEACeMGA8
> >> XQbR9R7/ojOv+zq+0PVtpA8=
> >> =kuS5
> >> -----END PGP SIGNATURE-----
> >>
> >>
> >
> >
Received on Saturday, 4 March 2006 23:47:20 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:54:42 UTC