W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2007

[whatwg] several messages about the naming of the loop attributes

From: Michael A. Puls II <shadow2531@gmail.com>
Date: Sat, 27 Oct 2007 20:59:26 -0400
Message-ID: <6b9c91b20710271759o29e9c249m474d5fba1e19b0ed@mail.gmail.com>
On 10/26/07, Ian Hickson <ian at hixie.ch> wrote:
>
> Bikeshed alert.
>
> On Fri, 19 Oct 2007, Michael A. Puls II wrote:
> > Now, I am suggesting:
> > currentLoop -> playIndex || currentPlayIndex || currentPlayCountIndex
>
> I have left this one for now. I don't like index, for reasons discussed
> below.

I see your point.

It's difficult to find something without 'loop' in it that's better
than currentLoop. Maybe that's a good sign.

> On Fri, 19 Oct 2007, Simon Pieters wrote:
> >
> > I don't have an opinion about naming in general, but I will note that
> > .playIndex is consistent with <select>'s .selectedIndex.
>
> For me this counts as a point against -- the selectedIndex identifies an
> item in a list, whereas here we are identifying a general period of time.


-- 
Michael
Received on Saturday, 27 October 2007 17:59:26 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:37 UTC