W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2007

[whatwg] several messages about the naming of the loop attributes

From: Ian Hickson <ian@hixie.ch>
Date: Fri, 26 Oct 2007 23:01:59 +0000 (UTC)
Message-ID: <Pine.LNX.4.62.0710262256130.7001@hixie.dreamhostps.com>

Bikeshed alert.

On Fri, 19 Oct 2007, Michael A. Puls II wrote:
> >
> > Maybe we should rename 'loopcount' to 'playcount'...?
> 
> playcount fits better with "the number of times to play the clip" than 
> loopcount does.

Ok. Done.


> > Hmm. Is the spec really ambigious?
> 
> Here's an example: [...]

What you're saying is that the attribute name is non-intuitive, not that 
the spec is ambiguous.

I agree. Changed as noted above.


> Now, I am suggesting:
> 
> loopCount -> playCount
> currentLoop -> playIndex || currentPlayIndex || currentPlayCountIndex

I have left this one for now. I don't like index, for reasons discussed 
below.


On Fri, 19 Oct 2007, Simon Pieters wrote:
> 
> I don't have an opinion about naming in general, but I will note that 
> .playIndex is consistent with <select>'s .selectedIndex.

For me this counts as a point against -- the selectedIndex identifies an 
item in a list, whereas here we are identifying a general period of time.


On Fri, 19 Oct 2007, Dave Singer wrote:
> 
> I have wondered whether it would be clearer if we called it loopFrom and 
> loopTo, and had loopCount be the count of the *extra* plays, and 
> loopNumber (or loopIndex) the current *extra* play.  So if loopCount is 
> 0, loopStart and loopEnd are irrelevant, and loopNumber will never 
> exceed 0 either.

I don't think loopFrom and loopTo is necessarily better than loopStart and 
loopEnd.


On Fri, 19 Oct 2007, Randy Drielinger wrote:
>
> The terminoly we currently have is the one that's being used in the 
> Video / Editting branch.
> 
> Although they don't sound too logical, we could keep these (thus making 
> it more consistent definition-wise) or perhaps pursue another name set 
> from an area and adapt those. I don't favor creating a new named set to 
> make things clear only for HTML5.0 sake.

Are you ok with the new names?


On Fri, 19 Oct 2007, Dave Singer wrote:
> 
> yes, and clarifying that there is a straight play from start to end, and 
> then loopCount extra plays from loopStart to loopEnd, counted by 
> loopNumber.  The same names with repeat instead of loop would also work.
> 
> is that clearer, easier to explain and understand?  so a loopCount of 0 
> means no loops, just the straight play.  loopNumber 0 means we have not 
> yet looped.

I'm not sure that loopCount = 0 is clearer than playCount = 1. In fact I 
think people get confused over loopCount too much, however it works.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Friday, 26 October 2007 16:01:59 UTC

This archive was generated by hypermail 2.3.1 : Monday, 13 April 2015 23:08:37 UTC