Re: New editor's draft (v20130603)

On 6/5/2013 4:59 AM, Adam Bergkvist wrote:
> On 2013-06-04 16:34, Randell Jesup wrote:
>>
>> One issue:   In RTCDataChannelInit:
>>
>>      boolean          negotiated 
>> <http://dev.w3.org/2011/webrtc/editor/webrtc.html#widl-RTCDataChannelInit-negotiated> 
>> =true;
>>
>> The default should be false - it should be set to true on any
>> externally-negotiated channel.
>
> Oh, I interpreted preNegotiated (skipped the "pre" -> negotiated) as a 
> property on the channel that makes the user agent negotiate the 
> channel for you in-band. I.e., it's pre-negotiated (or just 
> negotiated) meaning that you (the developer) doesn't have to worry 
> about negotiation; the opposite of "externally-negotiated".
>
> Should we use externallyNegotiated (default false) instead? That makes 
> sense on both sides.

I pushed the naming change into FF 22 Beta 4 at the last second (write, 
review, land, approve to uplift, land in one day).  I can't 
realistically get any further non-major-failure fixes in for FF22, where 
we'll be exposing this by default.  Unless there's a driving reason, I'd 
like to avoid in-the-field changes where possible, though they are 
doable (but that would mean people trying to use this would need to do 
"negotiated: true, externally-negotiated: true" for as long as they 
wanted to support FF22).

I'm ok with the name and description, so long as the default changes to 
'false', which is what I implemented and landed.  We should just comment 
in the IDL file that this should be set to true if the application is 
using external negotiation.   I believe Peter Thatcher was also assuming 
the default would be false.

>
> /Adam
>
>> We just landed code in FF to implement the rest of this (but with false
>> as the default) for Firefox 22 (the first release with RTCPeerConnection
>> enabled by default), with the old names as synonyms for the next release
>> or so (on Firefox 24 nightlies it will Warn in the Web Console if you
>> use the old names).  As of Firefox 24, we've begin to move
>> PeerConnection/etc from xpidl to webidl internally, which makes syncing
>> with the spec easier.
>>
>> We have not yet implemented all of the RTCDataChannel properties; we did
>> implement 'id' with the old 'stream' as a temporary synonym, and ordered
>> (and a few others) were already supported.
>>
>> Thanks for the update!  I'll check the rest of it more closely; sorry I
>> didn't get to it before it was published.

-- 
Randell Jesup
randell-ietf@jesup.org

Received on Thursday, 13 June 2013 16:56:39 UTC