W3C home > Mailing lists > Public > public-webplatform@w3.org > April 2014

RE: Notes.webplatform.org error frozenice found

From: David Kirstein <frozenice@frozenice.de>
Date: Sun, 20 Apr 2014 10:56:13 +0200
To: "'Renoir Boulanger'" <renoir@w3.org>, "'List WebPlatform public'" <public-webplatform@w3.org>
Message-ID: <002101cf5c76$623bdb60$26b39220$@frozenice.de>
Yay, it works! This should also help the performance, as browser clients don't need to resort to XHR-Polling anymore.

I updated our #webplatform-bot and it happily announces annotations again (in realtime). :)

When I posted my annotation, the server responded with a 500, although the annotation was successfully published. I tried it a second time and got no error back. Weird.
The log shows some "TPC in progress" and "Foreign transaction" exceptions at that time (2014-04-20 08:35:11). We should keep an eye on that.

Oh, and could it be that notes2 can't send mails? My password recovery mail didn't arrive. Those exceptions could also be related to this problem, as they mention "repoze.sendmail.delivery.MailDataManager".

-fro

-----Original Message-----
From: Renoir Boulanger [mailto:renoir@w3.org] 
Sent: Sonntag, 20. April 2014 03:20
To: David Kirstein; 'List WebPlatform public'
Subject: Re: Notes.webplatform.org error frozenice found

Hi Fro

I just upgraded the notes.webplatform.org webserver. It is now under
Ubuntu 14.04 LTS (released this week) and is now running with NGINX 1.4
which supports WebSocket protocol upgrade.

Tell me if you see any other kinks.

Renoir
~



On 2014-04-19, 4:21 PM, David Kirstein wrote:
> Hey Renoir,
>
>  
>
> I just checked it (busy day), it's different now, but not fine. :( Now we get a 400 when connecting to the WebSocket. You can see that on the normal pages too, btw. Just check the Network tab on Chrome DevTools and look for the __streamer__ websocket call.
>
>  
>
> I captured the packet to see what else it says besides 400 (sadly, the DevTools don't show that and I didn’t find anything in our server-logs):
>
> 400 Bad Request
>
> The server could not comply with the request since it is either malformed or otherwise incorrect.
>
> Can "Upgrade" only to "WebSocket".
>
>  
>
> Some googling shows code which checks if the Upgrade HTTP header lowercase-equals “websocket”.
>
>  
>
> Maybe that header doesn’t get passed along by Fastly or nginx?
>
>  
>
> -fro
>
>  
>
> -----Original Message-----
> From: Renoir Boulanger [mailto:renoir@w3.org] 
> Sent: Samstag, 19. April 2014 03:34
> To: David Kirstein; List WebPlatform public
> Subject: Notes.webplatform.org error frozenice found
>
>  
>
> Hey Fro—
>
>  
>
> I'd like to know if you still see the error related to
>
> notes.webplatform.org annotation server.
>
>  
>
> The code has been upgraded and I also adjusted NGINX proxy settings, it
>
> seems fine.
>
>  
>
> Keep me posted.





Received on Sunday, 20 April 2014 08:56:44 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:20:58 UTC