W3C home > Mailing lists > Public > public-webplatform@w3.org > November 2012

Re: problems moving API interfaces

From: frozenice <frozenice@frozenice.de>
Date: Fri, 16 Nov 2012 17:44:00 +0100
Message-ID: <50A66D50.3050108@frozenice.de>
To: public-webplatform@w3.org
See inline comments.

On 16.11.2012 17:20, Mike Sierra wrote:
> * There was a significant delay in moving the subpages, which threw me
>    off a bit. I'd suggest a note in the "move page" template about any
>    expected latency.
What do you mean exactly? You clicked the "Move page" button and the page took a while to load
or the page loaded and it took a while for the subpages to actually get moved to their new root?

> * The apis/css-regions page's "list subpages" option dumps a raw list
>    of links not only to each interface, but to each interface's
>    members.  Ideal in this context would be a table of interfaces,
>    featuring Name/Summary info generated from each subpage.
>
We could probably switch from PrefixIndex to SubPageList and add a checkbox for "kidsonly".

> * As a result of the move, the page for each interface lost the tables
>    referencing property/method/event subpages. That's because under
>    "Basic property configuration" for each member, the "Applies to API
>    object" field that defines the member's parent reflects the old
>    location. Can the "move" operation be modified to account for this?
Hmm, not out of the box. Maybe that's something for the planned admin-tool / bot.



Received on Friday, 16 November 2012 16:44:24 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 May 2013 19:57:35 UTC