W3C home > Mailing lists > Public > public-webcgm-wg@w3.org > October 2008

RE: ISSUE: WebCGMRect::union

From: Lofton Henderson <lofton@rockynet.com>
Date: Fri, 03 Oct 2008 08:46:06 -0600
Message-Id: <>
To: "Bezaire, Benoit" <bbezaire@ptc.com>, "WebCGM WG" <public-webcgm-wg@w3.org>
At 08:47 AM 10/3/2008 -0400, Bezaire, Benoit wrote:
>Don proposed 'unionRect()'
>I'm fine with that.
>Saying this issue will block implementers and test writers is a bit 
>strong. It takes 5 minutes to change the implementation side and tests. My 

I misunderstood.  I thought "it cannot be compiled" meant that implementors 
must change it (and could not proceed if they didn't -- that's what I meant 
by "blocked").

I guess each affected implementor could pick his own substitute name, but 
it would seem better to agree now, so the test writers and implementors can 
proceed on the same page.


>From: public-webcgm-wg-request@w3.org 
>[mailto:public-webcgm-wg-request@w3.org] On Behalf Of Lofton Henderson
>Sent: Thursday, October 02, 2008 7:08 PM
>To: Galt, Stuart A; Bezaire, Benoit; WebCGM WG
>Subject: RE: ISSUE: WebCGMRect::union
>At 01:09 PM 10/2/2008 -0700, Galt, Stuart A wrote:
>>I think that getUnion() would be similar to our other get/set routines.
>On the other hand, the 'get' routines are simply fetching something that 
>has been previously 'set'.
>>But do not have very strong feelings
>>one way or another.
>What is more important:  the WG should approve a tentative resolution as 
>soon as possible.  This is an issue that will actually block implementors 
>and test writers, if I understand correctly.  Would it be a good idea to 
>implement and write tests to the tentative resolution, instead of the 
>actual LC spec?
>>From: Bezaire, Benoit [mailto:bbezaire@ptc.com]
>>Sent: Thursday, October 02, 2008 11:34 AM
>>To: WebCGM WG
>>Subject: ISSUE: WebCGMRect::union
>>union() is not a good method name. Given that 'union' is a C/C++ keyword, 
>>it cannot get compiled by the MIDL compiler (on Windows).
>>We need a new name. Either:
>>i) Union(): but we have so far, started method names using lower cap 
>>ii) calcUnion() or getUnion(): or something similar.
Received on Friday, 3 October 2008 15:04:27 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:23:40 UTC