W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2011

Re: [WARP] error in spec

From: Marcos Caceres <marcosscaceres@gmail.com>
Date: Thu, 2 Jun 2011 17:13:56 +0200
Message-ID: <BANLkTimEVVb1jx5jsa4XsFwQ_Vh=yz45pA@mail.gmail.com>
To: public-webapps <public-webapps@w3.org>, Robin Berjon <robin.berjon@gmail.com>, Marcos Caceres <marcosscaceres@gmail.com>
Cc: Hari Kumar G <harig@opera.com>
On Thu, Jun 2, 2011 at 9:26 AM, Marcos Caceres <marcosscaceres@gmail.com> wrote:
> Quote from WARP:
>
> """
> Let sub domains be the result of applying the rule for getting a
> single attribute value to the value of the subdomains attribute. If
> the value of sub domains is not a valid boolean value, then this
> element is in error and the user agent MUST ignore this element.
> """
>
> subdomains has a default value of false so why is ignoring the
> complete <access> element needed?  If only the subdomains is to be
> ignored, then the steps for processing the config.xml need to be
> changed to include the default value.
>

I've removed the following two tests from the test suite until we get
this resolved:

# ic (download, files)
Tests that the UA ignores an access element with an invalid subdomains
value. To pass, the remote script must NOT load and PASS must remain
displayed.

# id (download, files)
Tests that the UA ignores an access element with an invalid subdomains
value. To pass, the remote script must NOT load and PASS must remain
displayed.



-- 
Marcos Caceres
http://datadriven.com.au
Received on Thursday, 2 June 2011 15:14:44 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:45 GMT