W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2011

Re: [FileAPI] File.slice spec bug

From: Darin Fisher <darin@chromium.org>
Date: Tue, 12 Apr 2011 16:25:53 -0700
Message-ID: <BANLkTimkxvdLWeZSUzGni8fmb3PHARsXUA@mail.gmail.com>
To: Mike Taylor <miketaylr@gmail.com>
Cc: Jonas Sicking <jonas@sicking.cc>, Dmitry Titov <dimich@chromium.org>, Kyle Huey <me@kylehuey.com>, Jian Li <jianli@chromium.org>, "arun@mozilla.com" <arun@mozilla.com>, Maciej Stachowiak <mjs@apple.com>, Web Applications Working Group WG <public-webapps@w3.org>, Eric Uhrhane <ericu@google.com>
On Tue, Apr 12, 2011 at 4:02 PM, Mike Taylor <miketaylr@gmail.com> wrote:

> On 4/12/11 2:05 PM, Jonas Sicking wrote:
>
>> It appears that Opera too implements File.slice. Would be great to
>> know for how long it's been implemented.
>>
> The first public build [1] with File.slice was made available last week.
> It's only been officially supported as of today, however, with the release
> of 11.10.
>
> [1] http://my.opera.com/desktopteam/blog/2011/04/05/stability-gmail-socks
>
> - Mike
>


As Jian mentioned earlier, File.slice has been available in Chrome since
version 6, which was released Sept 2, 2010:
http://googlechromereleases.blogspot.com/2010/09/stable-and-beta-channel-updates.html

It seems like too much time has passed with this feature baked into Chrome
for us to be able to change its behavior now.  While I agree that it would
be nice for ".slice(...)" to work the same way in all contexts, I'm just not
sure that this is something we can remove from Chrome at this point or even
change.

I'm very concerned about breaking existing web content.

A new name for this function might be nice, but once you do that then I'm
not sure that its arguments should really be any different than the current
arguments for Blob.slice().  What's wrong with "start" and "length" other
than that the fact that it differs from the parameters to Array.slice?  Why
should Blob.createSubBlob favor the argument style of Array.slice over
Blob.slice?

I guess I'm leaning toward no change at all and just taking our lumps for
having created an inconsistent API :-/

-Darin
Received on Tuesday, 12 April 2011 23:26:37 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:44 GMT