W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2010

Re: Lifetime of Blob URL

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 30 Aug 2010 13:08:40 -0700
Message-ID: <AANLkTin7tbiEB-k30OMFJO1jmBqd0e+MXNh7N_eT+8BZ@mail.gmail.com>
To: arun@mozilla.com
Cc: Jian Li <jianli@chromium.org>, Eric Uhrhane <ericu@google.com>, Dmitry Titov <dimich@chromium.org>, Michael Nordman <michaeln@google.com>, David Levin <levin@google.com>, Adrian Bateman <adrianba@microsoft.com>, Darin Fisher <darin@chromium.org>, Web Applications Working Group WG <public-webapps@w3.org>
On Mon, Aug 30, 2010 at 9:59 AM, Arun Ranganathan <arun@mozilla.com> wrote:
>> In addition, BlobError and BlobException sound better because these names
>> are consistent with current "Blob" naming scheme in File API. So we're also
>> going to adopt these new names in the WebKit implementation when we rename
>> FileReader to BlobReader per the spec.
>
> *sigh.  Naming continues to be hard.  Not everyone's thrilled with the
> proliferation of Blob in the API [1] including other major implementors (my
> co-editor included ;-))  but I changed it mainly due to Darin/Jian/other
> objections.  I suppose you folks are pretty adamant on the Blob* name?

I feel pretty strongly that we should name this back to FileReader,
for several reasons:

1. Most people that I talk to dislike the name Blob, much less having
it spread to things like BlobReader.
2. My understanding is that the writer counterpart is going to be
called FileWriter (is this correct?)
3. While it's certainly possible to read Blobs with this, it seems to
me like the far most common case will be to read a "real" file, or
part of a file (i.e. the result from myfile.slice()).
4. There is one shipping implementation of FileReader

/ Jonas
Received on Monday, 30 August 2010 20:09:37 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:40 GMT