W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2010

Re: IndexedDB - renaming

From: Jonas Sicking <jonas@sicking.cc>
Date: Thu, 10 Jun 2010 10:29:45 -0700
Message-ID: <AANLkTilmmFTfeUIULPFisei-oofEvDJO5klXFRxnsTSC@mail.gmail.com>
To: Andrei Popescu <andreip@google.com>
Cc: Webapps WG <public-webapps@w3.org>
Arg, drats, I missed the "planning" part of your email :)

Sounds good to me, the only thing I would add is that I think we
should remove the base-interfaces, like IDBObjectStore, and copy the
relevant properties to both (async and sync) sub-interfaces.

/ Jonas

On Thu, Jun 10, 2010 at 10:27 AM, Jonas Sicking <jonas@sicking.cc> wrote:
> I still see the old "Request" post-fixed names when looking at
>
> http://dev.w3.org/2006/webapi/IndexedDB/#async-api
>
> Despite the top of the file saying that this is the June 10th version.
> Is there somewhere else I should look?
>
> / Jonas
>
> On Thu, Jun 10, 2010 at 9:38 AM, Andrei Popescu <andreip@google.com> wrote:
>> Hello,
>>
>> A while ago, we discussed some simple renaming of the IndexedDB
>> interfaces. I have already closed
>>
>> http://www.w3.org/Bugs/Public/show_bug.cgi?id=9789
>>
>> as it was a very simple fix. I would like to recap the rest of the
>> changes I am planning to make, just to make sure that everyone is ok
>> with them:
>>
>> 1. Drop the "Request" prefix from our async interface names and add
>> the "Sync" suffix to the sync interfaces.
>>
>> http://www.w3.org/Bugs/Public/show_bug.cgi?id=9790
>>
>> 2. Rename IDBIndexedDatabase to IDBFactory. My original proposal was
>> also renaming IDBDatabase to IDBConnection but Jonas had an objection
>> to that. So let's keep it IDBDatabase for now.
>>
>> http://www.w3.org/Bugs/Public/show_bug.cgi?id=9791
>>
>> What do you think?
>>
>> Thanks,
>> Andrei
>>
>>
>
Received on Thursday, 10 June 2010 17:30:37 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:39 GMT