W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2010

IndexedDB - renaming

From: Andrei Popescu <andreip@google.com>
Date: Thu, 10 Jun 2010 17:38:23 +0100
Message-ID: <AANLkTikAWiKTG1kv3GlHF7XoBnzL_qsgmdAaksQi8pOr@mail.gmail.com>
To: Webapps WG <public-webapps@w3.org>
Hello,

A while ago, we discussed some simple renaming of the IndexedDB
interfaces. I have already closed

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9789

as it was a very simple fix. I would like to recap the rest of the
changes I am planning to make, just to make sure that everyone is ok
with them:

1. Drop the "Request" prefix from our async interface names and add
the "Sync" suffix to the sync interfaces.

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9790

2. Rename IDBIndexedDatabase to IDBFactory. My original proposal was
also renaming IDBDatabase to IDBConnection but Jonas had an objection
to that. So let's keep it IDBDatabase for now.

http://www.w3.org/Bugs/Public/show_bug.cgi?id=9791

What do you think?

Thanks,
Andrei
Received on Thursday, 10 June 2010 16:38:52 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:39 GMT