W3C home > Mailing lists > Public > public-webapps@w3.org > April to June 2010

[Bug 9791] New: IDBDatabase should (possibly) be renamed to IDBConnection

From: <bugzilla@jessica.w3.org>
Date: Fri, 21 May 2010 16:33:28 +0000
To: public-webapps@w3.org
Message-ID: <bug-9791-2927@http.www.w3.org/Bugs/Public/>

           Summary: IDBDatabase should (possibly) be renamed to
           Product: WebAppsWG
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Indexed Database API
        AssignedTo: nikunj.mehta@oracle.com
        ReportedBy: jorlow@chromium.org
         QAContact: member-webapi-cvs@w3.org
                CC: mike@w3.org, public-webapps@w3.org

Andrei Popescu proposed a couple naming changes to the interfaces within
IndedexDB deep within the "[IndexDB] Proposal for async API changes" thread

One of the proposals was to change IDBDatabase to IDBConnection.  This proposal
met with some opposition (unlike the other two) and thus should probably be
discussed further and possibly marked as invalid.

The voices are Andrei, Shawn, Jonas, and Jeremy in that order:

> >>> - Some of the interfaces could have names that would more closely
> >>> reflect their roles in the API. For instance, IDBDatabase could be
> >>> renamed to IDBConnection, since in the spec it is described as "a
> >>> connection to the database".
> >>
> >> This sounds good as well.
> >
> > Not really sold on this. I've always hated the "connection"
> > abstraction. With our suggested API IDBDatabase really just holds
> > metadata information about the database, and doesn't need to represent
> > a connection at all.
> Well, if we don't make these proposed changes, then I think it's pretty important
> to rename to connection since the current spec does distinguish between each
> connection.
> With your proposal, this is not currently true, but I think it's hard to say whether
> or not these concepts will creep back in in later versions.  In addition, the entire
> spec is related to databases, so I think naming it a "connection" rather than a
> "database" helps distinguish it from the rest.
> That said, if IndexedDatabase* becomes IDBFactory* then there certainly is a lot
> less confusion already, and this change is less important.

[1] http://lists.w3.org/Archives/Public/public-webapps/2010AprJun/0801.html

Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Friday, 21 May 2010 16:33:30 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 11 February 2015 14:36:43 UTC