W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2009

Re: [Window/View Modes] Naming + Feature vs. Query: suggested changes

From: Marcos Caceres <marcosc@opera.com>
Date: Tue, 18 Aug 2009 14:52:46 +0200
Message-ID: <b21a10670908180552p4286500ajfdee3008e9678767@mail.gmail.com>
To: Marcin Hanclik <Marcin.Hanclik@access-company.com>
Cc: "public-webapps@w3.org" <public-webapps@w3.org>
On Tue, Aug 18, 2009 at 2:37 PM, Marcin
Hanclik<Marcin.Hanclik@access-company.com> wrote:
> Hi Marcos,
> It seem to get an off-topic discussion...

Apologies; I rushed my responses.

>>>> Do we care about "non-widgets" using view modes?
>>>Of course not :)  The technology should be generally applicable where possible.
> I assume you meant "yes", or?

Yes. We do care. We want to make this as widely applicable as
possible, but not more.

>>>Lets not repeat the same mistakes we made with P&C (namely calling the
>>>widget element "widget" instead of something more generic, like
> What about consistency?
> Why is "widget" something else than a "package"?

Because it implies something else [2]. The P&C should just have been a
generic packaging format (which it is, but comes with "widget"

> [2] seems to have a problem with the definition of a widget (aka applet), so if it is so undefined, it can be regarded as generic as well, I think.

Yeah. This is a bikeshed. It is what it is, I need to get over it.

> Even if some people are unhappy with widget vs. package or so, then it seems it is quite late.
> It makes little sense as for me to change the naming in the middle of the specification of the whole "widget" architecture/model defined by [1].
> If we keep <widget>, but remove "widget" in other places the architecture will be broken.
> P&C says:
> "This specification standardizes a packaging format for software known as widgets. Widgets are client-side applications ..." -> this seems to apply also to modes spec.
> "This specification is part of the Widgets 1.0 family of specifications, which together standardize widgets as a whole."
> "The Widgets 1.0: Media Query Extensions, which defines extensions to CSS Media Queries, and a DOM interface for querying the media features of a widget (see [Widgets-Views])."
> The last statement from the above will probably have to be updated anyway.
> I think we should remain around widgets and keep the related naming.

Ok, yes. Lets progress with the widget prefixes where you deem necessary.

> Otherwise probably the viewmodes should be co-standardized by CSS WG.

That would be nice and helpful. I'm sure we will have to get them to
help us at some point regardless. We are stepping on their toes with
this spec, after all. Our aim should be to get this spec to a point
where we can take the spec that the CSS working group for review and

> BTW: My question about WidgetViewModeChangeEvent vs. ViewModeChangeEvent remains without answer.

Right, please change it to what you suggested:

> interface ViewModeChangeEvent : Event {
>  readonly attribute DOMString viewMode;
> ...
> };

Marcos Caceres
Received on Tuesday, 18 August 2009 12:53:51 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:18 UTC