W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2008

Re: [selectors-api] Names of querySelector() and querySelectorAll() methods

From: Lachlan Hunt <lachlan.hunt@lachy.id.au>
Date: Fri, 21 Nov 2008 16:50:18 +0100
Message-ID: <4926D8BA.1060604@lachy.id.au>
To: Gavin Kistner <gavin@phrogz.net>
CC: public-webapps@w3.org

Gavin Kistner wrote:
> I find these names rather cumbersome and not very self-explanatory.

I agree.

> Though it may be far too late for this suggestion, I would suggest that 
> they should be something such as:
> findNode()/findNodes() or findNode()/findAllNodes()
> selectNode()/selectNodes() or selectNode()/selectAllNodes()
> findBySelector()/findAllBySelector()

However, unfortunately, given the significant amount of prior discussion 
of this issue and the formal process which led to the selection of the 
current names; and the fact that we have implementations due to be 
released in upcoming versions of each of the 4 major browsers, changing 
the name at this stage is not possible.

Please let me know whether or not you are satisfied with this response.

Lachlan Hunt - Opera Software
Received on Friday, 21 November 2008 15:51:01 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:12 UTC